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About this User Guide 
 

Why'd we create a User Guide? 

This User Guide was made because customers wanted an organized, simple, and easy-to-find collection of information about ProFile's 
features. It's also designed to help new employees get started quickly. This means they don't need to get a lot of help. 

​
For new ProFile customers ​
You will find a wealth of easy-to-review material that covers the basic functionality of ProFile. You can come back to the User Guide as the tax season 
progresses, or as the way you use ProFile changes. It has a lot of information that is covered in our support articles, which are updated regularly.  

​
For returning ProFile customers ​
You probably already know the basics (and even the advanced) functionalities within ProFile. The User Guide contains a ton of information in one 
convenient, easy-to-use document that you can review, print, and bookmark. 

​
​
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System Requirements for ProFile 
 

●​ Internet connectivity is required for activation, licensing, automatic updates, and additional ProFile features (for example, EFILE) 
●​ Network/workstation install UNC path isn't supported 
●​ Operating system Windows 10™, Windows 11, Windows Server 2016, and 2019 
●​ .NET 4.8 installation and registration are required 

 

⚠️Note: Apple products aren't supported. 

 

ProFile contains very sensitive data. Intuit won't be responsible for security or other reliability issues for ProFile running on 
Windows 10 systems. 

Microsoft is set to deprecate Windows 10 as of October 14, 2025. After this date, Windows will no longer provide free security updates or 
technical support will be available for Windows 10. This can impact the security and reliability of any programs running on your system. We 
strongly encourage you to upgrade for free to Windows 11 to continue getting Microsoft Support. 

If you choose not to upgrade to Windows 11 from Windows 10, we strongly recommend purchasing the Extended Security Upgrade (ESU) 
program to keep your device secure.  

For the most up to date system requirements,  check out our system requirements.  

 
11 

 

https://www.microsoft.com/en-ca/windows/get-windows-11
https://learn.microsoft.com/en-ca/windows/whats-new/extended-security-updates
https://learn.microsoft.com/en-ca/windows/whats-new/extended-security-updates
https://profile.intuit.ca/support/system-requirements/?src=ProFileUserGuide


 

 
 
 

Getting Started with ProFile 
 

 
12 

 



 

Downloading and Installing ProFile 
​
An internet connection is required to download and install ProFile. You’ll also need administrator rights for the computer on which you wish 
to install ProFile. 

​
Download ProFile 
 

1.​ Browse to the ProFile download page. 

2.​ Determine if you are a new customer, returning customer, if you require OnePay, or a reinstall of ProFile. 

3.​ Follow the necessary instructions. Often, the requirement will include the download of the ProFile installation file (called 
gpsetup.exe). 

4.​ Your web browser may ask you to confirm if the file download can continue. Select Yes or OK when prompted.  

⚠️Note: If asked to choose a place to store the installation file, we suggest your computer's Desktop or Downloads folder, or another 
easy-to-find folder. 

The download may take several minutes.​
 

Install ProFile 
 

1.​ Locate the saved gpsetup.exe installation file. 

2.​ Double-click the file to begin the installation. 

3.​ Follow the dialogue boxes when prompted to install ProFile. 
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​
Activating ProFile 
​
⚠️Note: An Internet connection is required to activate ProFile. Also, you 
must have administrator rights for the computer on which you wish to install 
ProFile.  

Activating from the ProFile icon 
 

1.​ Locate the ProFile icon on the computer desktop. It installs there during 
the download and activation process.  

2.​ Double-click the ProFile icon. 

The Activate New License prompt displays when ProFile opens. The product 
code field can remain empty. The license key information is provided to you on 
your purchase receipt. 

3.​ Enter your License Key and select Activate. 

The license key activates. ProFile displays a confirmation message. Once 
activated, you can close the confirmation window. 

4.​ Select Add another license to add more licenses, if necessary. If you 
have purchased additional licenses for a module, enter the License Key 
only once on each additional computer. 

5.​ Select I’m Done after all product codes have been entered. Activation may take a few minutes to complete. 

ProFile displays a message requesting a check to determine if you are using the most current version of the software. You can skip or delay 
this check, or select OK to continue with the check. 

✅You have successfully activated ProFile. 
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Checking Your Version of ProFile 
​
ProFile is constantly undergoing improvements and adding to its features to benefit 
customers. It's important for Preparers to have the latest version to ensure the full 
functionality of ProFile is available.  

In addition, knowing where and how to check the version of ProFile is helpful in the 
case of a support call. ProFile’s Care representatives will often ask which version of the 
software is in use when troubleshooting an issue.​
 

Checking ProFile version: 

1.​ Open ProFile. 

2.​ Select the About option from the Help dropdown menu.     

The About window displays. 

3.​ Review the ProFile version number (for example, 2025.1.5).  
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Updating ProFile to the Latest Version 
During the tax season, ProFile updates with new CRA information, tax rates, forms, and more. 
It's important to keep ProFile up to date to ensure compliance with the latest CRA 
requirements. The recommendation is to check - at the very minimum - once per week.  

 

Updating ProFile: 

1.​ Open ProFile. 

2.​ Select the Check for Updates… option from the Online dropdown menu. 

ProFile connects to the Internet to see if there are any available updates. If there are, you are 
prompted to download and install the newest update.  

3.​ If no updates are available, select OK to close the window. 

Automatic Check for Updates 

You can enable ProFile to automatically check for updates.  To enable this feature, 

1.​ Select Options from the menu , then select Environment Options… 

2.​ Select the System tab. 

3.​ In the Automatic Check for Updates section, tick the Enable automatic check for 
updates box 

 

Background Updater 

In the Automatic Check for Updates section, check the Enable check for updates box. This lets 
you download updates automatically in the background, without disrupting your work. You can 
locate the Automatic Check for Updates section, under Enable automatic check for 
updates. 

Once the check box has been enabled, you will see a status box in your icon tray.   

 

 
16 

 



 

Using ProFile 20 
​
ProFile 20 is a bundle of 20 returns that provides a more cost-efficient alternative to Preparers than buying individual OnePay returns. It's 
best suited for Preparers who have 20 or fewer T1/TP1 returns to file. 

ProFile 20 supports T1/TP1 returns for tax years 2015-2025 

ProFile 20 customers are charged a return ONLY when they EFILE a return or print a return using the T1 Condensed setting. 

 

Getting started 

Visit our ProFile 20 website or call our sales team at 1-844-861-3600 to purchase ProFile 20.  

 

Accessing ProFile 20 

ProFile 20 customers receive an email containing their License Key. 

1.​ Open ProFile. 

2.​ Select the Manage Licenses option from the Help dropdown menu. The License wizard displays. 

3.​ Select Add New License, the ProFile License Activation window displays. 

4.​ Enter the License Key from the email and select Activate. 

The ProFile license activates. You can now print and EFILE T1/TP1 returns using ProFile 20. 

 

Am I charged a ProFile 20 return if I just prepare a return? 

No. ProFile 20 customers can prepare as many T1/TP1 returns as they like without being charged. 

 

Does ProFile 20 work with Flexible Licensing? 

Yes. 
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How many ProFile 20 licenses can I buy at one time? 

Only a single ProFile 20 license may be purchased at one time. 

If more than 20 returns need to be filed or printed, Preparers can purchase another ProFile 20 license when all returns are used or opt for 
OnePay or purchase the unlimited version. 

 

Will I get a refund for unused ProFile 20 returns? 

No, there are no refunds provided for unused ProFile 20 returns. 

 

Can I use the remaining returns on my ProFile 20 for the next year? For example, can I use the 20248 license for 2025 returns? 

No. In this example, any remaining ProFile 20 returns would need to be used to EFILE or print prior year returns. 

 

Will I be notified how many ProFile 20 returns I have remaining when submitting or 
printing a return? 

An assessment window displays the remaining number of ProFile 20 returns when a 
return is used.  

 

Will I be informed when all ProFile 20 returns have been used? 

A notification window indicates when all ProFile 20 returns have been used: 

 

Related Articles 

Review our support article for additional details. 
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Managing OnePay in ProFile 
 

Overview of ProFile OnePay 
 
OnePay is a one-time license that allows a ProFile customer to file a single T1, T2, or T3 return. It's an alternative to purchasing a full ProFile 
license, which lets you do unlimited returns. 

OnePay is best suited for: 

●​ An existing ProFile customer whose license has expired, but still needs to file a return or returns 
●​ A new ProFile customer with a limited number of returns to be filed 
●​ A resident of Quebec at the end of the fiscal year, and only the Federal module has been purchased and not the Quebec TP1 or the 

Quebec T646* 
●​ A ProFile customer with a business registered in Quebec*​

 
⚠️Note: In the event of the OnePay purchase is for Quebec, the Preparer is required to NetFile the TP1 separately from the Federal. They 
also require a NetFile QC Number and Access Code. For more information, visit Revenu Québec. 

⚠️Note: If the taxpayer resides in any other Province and has an RL-1, the TP1 return isn't necessary. The RL-1 information may be 
entered in the T4 form. 
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Purchasing ProFile OnePay 
 
OnePay is purchased only from within ProFile. An internet connection is required to complete the purchase via our secure web page. 
 
⚠️Note: if purchasing a OnePay for a recurring client, carry forward the return(s) before purchase. If you purchase the OnePay prior to 
carrying forward the file, it may consume the OnePay license. 
 

1.​ Open the necessary return in the appropriate module (for example, T1). 

2.​ Select the Star icon  from the top toolbar menu in ProFile or select the Purchase OnePay... option from the File menu. 

The product selection wizard displays.  

3.​ Select Get Started under the OnePay option. 

The license purchase menu displays. 

4.​ Select Add to cart to purchase a license based on the required 
module(s). 

5.​ Select Proceed to checkout when prompted to purchase. 

6.​ Enter the necessary company and billing information. 

7.​ Select Continue, the Payment Information window displays.  

8.​ Enter the necessary payment information and select Continue. 

The Review Your Order window displays. 

9.​ Review the payment and purchase information. If correct, select Place Order. 

The confirmation window displays the OnePay order and cost. 

10.​Select the close this window link. The link is highlighted in the screenshot. 

The OnePay payment wizard closes. 

11.​The Preparer returns to ProFile and to the return being filed. 

 
20 

 



 

Troubleshooting ProFile OnePay 
 
I received an error message at the end of a OnePay purchase transaction. 

When purchasing OnePay through ProFile's OnePay Purchase wizard, the following error may appear: 

"Your online purchase transaction was not completed. Please go back and review your selections". 

This isn't a ProFile error, but could be resulting from one of the following situations: 

●​ High security settings on the computer (see solutions below) 
●​ A network disruption (check your network is functioning) 
●​ The transaction timed-out (retry the transaction to completion) 

The following are solutions that may resolve the high security setting issue: 

●​ Check ProFile version is the latest 
●​ Check Windows Update for any recent OS updates 
●​ Set firewall/antivirus exception for ProFile 
●​ Set SSL/TSL security 
●​ Allow pop-ups 
●​ Clear your cache and browsing history 
●​ Check for Proxy settings 
●​ Check .NET version is the latest 

​
Can I purchase more than a single OnePay? 

When purchasing One-Pay, only one unit can be purchased at a time. If you enter more than one number in the Quantity field, you will be 
charged for that number, but you will only get one license. 

I'm being prompted to purchase OnePay. 

If a ProFile customer attempts to populate a form for any module (for example, T1, T2, or T3) without an existing valid ProFile license, the 
OnePay purchase wizard displays.​
 

Can I use Auto-fill my Return (AFR) with OnePay? 

Yes. Prior to using AFR with OnePay the Preparer requires: 

●​ An EFILE account 
●​ A representative ID 
●​ A filed & active T1 Authorize a representative request with CRA 
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Review the CRA article to learn more about authorizing or canceling a representative.​
​
I downloaded a trial version of ProFile, but when I try to evaluate the software, the OnePay Wizard appears, asking me to purchase 
a return. 

When installing a ProFile Trial version, make sure you insert the new License Key in the License window.​
​
I'm seeing a trial watermark written through all the forms when I print the return using a OnePay license. 

This happens because the Trial license and the OnePay are both activated in ProFile at the same time and the Trial license is overriding the 
OnePay. 

In ProFile: 

1.​ Browse to the Help -> License -> Details option. 
2.​ Select the Trial License option. 
3.​ Select the Delete Selected License option. 
4.​ Close the Licensing window 
5.​ Open the file to print by browsing to the File -> Open option. 
6.​ Print normally. 

⚠️Note: If you have removed a Trial License and still get a trial watermark, call support for help. 
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QuickStart Menu in ProFile 
The QuickStart menu makes getting started with ProFile easier and faster.  

QuickStart menu tabs 

Each available module occupies a tab along the top of the QuickStart menu. 

Each module tab features a small black arrow that expands to 
display previous tax years. 

Links from the QuickStart window let Preparers easily undertake 
the following:  

▪​ Create a new file, or return 
▪​ Open an existing file that was previously saved 
▪​ Carry forward a file from a previous taxation year to the 

current taxation year 
▪​ Open a file that was recently worked on 
▪​ Access in-product Help, user forums, and more support 

resources 

Turn off the QuickStart menu: 
 
The QuickStart menu can be turned off if you prefer not to use its 
functionality. 
 

1.​ Identify the checkbox in the bottom corner of the 
QuickStart menu. 

2.​ Toggle off the checkbox.The QuickStart menu will no 
longer appear when ProFile starts. 

3.​ To re-establish the QuickStart menu later, select the Help and then QuickStart.  
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Using a Trial License in ProFile 
 
A trial license gives Preparers the opportunity to try the functionality of ProFile without any cost. 

 

What’s included with a trial license? 

A trial includes access to all the modules and features ProFile has to offer, except for filing completed tax returns, print features, access to 
Intuit Sign, and access to the CRAs AFR service.. These features include:  

●​ T1/TP1 for Individual tax returns 
●​ T2 for Corporate tax returns 
●​ T3/TP-646 for Trust returns 
●​ FX/FXQ for additional forms (T4/T5, etc.) 

​
Getting a trial license 

1.​ Visit the free trial section of the ProFile website. 

2.​ Sign in to your One Intuit Account, or create an 
account if you don’t have one. 

3.​ Complete the information fields throughout the 
wizard. 

4.​ Review the information and Place Order. 

The temporary license key is provided via email. 

5.​ Download ProFile, enter your license key, and begin your free trial. 

 

 
24 

 

http://profile.intuit.ca/professional-tax-software/free-trial.jsp?src=ProFileUserGuide


 

 

 
 

Set Up & Settings  
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Using the Start Screen in ProFile 
​
The ProFile start screen contains most of the options and elements required to complete forms and slips. When starting ProFile for the first 
time, many of the action icons will be “greyed out” or inactive. Once forms and slips are created, many will become active for use. 

​
The top toolbar menu 

ProFile’s top toolbar menu has the most options to begin completing and filing client returns. Below are some of those features: 

​
​
 

The File menu includes many of the functional features for ProFile, including Open a return, Carry Forward, Import Data, and Print. 

The Goto menu activates the ProFile database options of Form Explorer and Client Explorer. 

The Form menu allows users to open, print, and close forms in ProFile, as well as clear populated forms. 

The Options menu allows Preparers to customize the ProFile environment, module, database, templates, pricing, and other features. 

The EFILE menu displays current and archived EFILE returns, as well as the ability to set EFILE options. 

The Online menu connects users to online support materials, the Live Community, and software updates. 

The Training menu lists in-product tutorials for individual tax years and modules.  

The Window menu gives ProFile users the ability to reorient the view of ProFile. 

The Help menu links users to support materials, flexible licensing options, and the in-product Help feature. 
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Setting Preparer Information in ProFile 
​
Preparer information can be easily entered in ProFile. This lets the Preparer section 
of ProFile Info forms to automatically populate whenever a new form is created. 

1.​ Select Environment… from the Options dropdown menu. 

The Environment Options window displays. 

2.​ Select the Preparer tab. A list of information fields displays. 

3.​ Complete the necessary fields.  

4.​ Select OK. 

✅The Preparer information saves.​
 

Automatically updating Preparer information changes 

Preparers can set an automatic update for the Preparer section of returns when 
changes are retroactively made to the Preparer information. For example, if the 
name of the Preparer’s firm changes, the returns with the firm’s name 
automatically update to the new name. 

1.​ Select Module… from the Options dropdown menu.​
 

2.​ In the General tab, scroll down to the Options section.​
 

3.​ Activate the Update Preparer information on Info form checkbox.​
 

4.​ Select OK. The settings are saved.  
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Setting up for EFILE in ProFile 
 
Prior to using the EFILE function for a return, it's necessary to use the set-up wizard in ProFile.  
 
Setting up for EFILE: 
 

1.​ Select the Set EFILE Password option from the EFILE 
dropdown menu. 

The EFILE Wizard displays. 

2.​ Select Next to continue. 

3.​ During the Set EFILE Password process, users will require the 
following: 

●​ EFILE On-Line Number (from CRA) 
●​ EFILE On-Line Password (from CRA) 
●​ NetFile Quebec Number (if applicable, from MRQ) 
●​ NetFile Quebec Password (if applicable, from MRQ) 
●​ EFILE number (from CRA) 

4.​ For federal filing, you will enter your EFILE Number as well as 
the Password provided to you by CRA.  The new requirement 
from CRA is to re-enter the password to ensure it's correct and prevent EFILE failures.  Select Next. 

5.​ If you are registered for NetFile from MRQ, enter your EFILE Number and Access code enter the information on this screen.  Select 
Next. Then enter your CRA EFILE Number again, and select Next. 

6.​ Select Finish when all applicable information is entered. 

 
⚠️Note: If you are using an Options Package, save the options package after entering in the new EFILE information. 
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Creating a New File in ProFile 
​
Creating a new file or return in ProFile is quick and convenient.  
 
⚠️Note: Only tax modules that have been purchased can be created in 
ProFile. However, previous tax years are made available for the purchased tax 
module. 
 
Creating a new file in the current tax year 
 

1.​ Open ProFile. 

2.​ Select the New option from the File dropdown menu. 

A list of available modules displays in the menu. 

3.​ Select the desired module. A new return opens in ProFile. 

Alternatively, you can use the new  icon  More detailed module 
information can be chosen from the dropdown arrow beside it.   

Creating Older Files 
 
There are three options under the New option in the File dropdown menu for older modules: 
 

●​ Older T1/TP1 Modules 
●​ Older T3 Modules 
●​ Older FX Modules 

 
1.​ Select the applicable option for creating an older module (for example, T1/TP1). A list of previous 

tax years supported by ProFile displays. 

2.​ Select the desired module. A new return opens in ProFile. 
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1.​ Use the filter options to identify which files to carry forward. For example, if you only want to carry forward T1 files from the year 

2018, select the T1 module tab, then the 2018-year designation. 

2.​ Select Apply Filters. The files matching the selected filter options display. 

3.​ Select the files to carry forward. To select all files, right-click in the window and choose Select All from the pop-up menu. All files are 
highlighted. 

4.​ Right-click on the 
selected file(s) and 
select the Carry Forward 
Files option from the 
menu.  

 

✅The file(s) are carried 
forward. 

 

Related Article: 

Review our support article on 
carrying forward files using the 
Client Explorer database. 
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Using Additional ProFile 
Features 
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Fast Reopening of Files 
 
ProFile lets Preparers quickly reopen returns that they have recently worked on.​
​
Fast reopen of returns: 

1.​ Select the arrow next to the file folder icon in the top ProFile toolbar. 

A list of recently opened returns displays.  

2.​ Select the return to continue working on. The return opens. 

⚠️Note: Preparers can also review a list of recently opened returns under the File menu in the top ProFile toolbar. 
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Carry Forward Files in ProFile 
​
Carry forward is a ProFile service that lets an existing client information  from a previous year’s files be moved forward into a new file. This 
saves time and effort for Preparers. Preparers can also carry forward a previous year’s ProFile file, or a file prepared using a competitor’s 
product, as well as multiple files at one time. 

Carry forward files in ProFile: 

1.​ Select the Carry Forward… option from the File 
dropdown menu. 

2.​ Select the module (for example, T1) and tax year of 
the file to carry forward from the dropdown list. 

3.​ Select the specific file to carry forward. 

4.​ Select Carry forward 

✅The selected file carries forward. 
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Batch Carry Forward Files 

 

ProFile has a feature called Carry Forward Files. This feature lets you bring back the results from the past year into the current module. 

1.​ Open Client Explorer in ProFile.  

Client Explorer displays a list of tax return files. 

2.​ Select Filter. The filter menu displays at the bottom of the Client Explorer window. 

3.​ Select files to carry forward (for example, all T1 files) and the previous year (for example, 2024) from the checkbox menu.  

4.​ Select Apply Filters. The filter will display all files meeting the selected criteria. 

5.​ Select the Select All 
link.  

6.​  Select the Carry 
Forward Files option. 

✅The files carry forward.​
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Carry Forward Competitor Returns in ProFile 

Tax Cycle 
 

What years are supported for conversion?  

The T1 module supports 2021–2024 files. The T2 module supports T2 2016–2024 and later files. Version 14.2.57271.09 of TaxCycle is 
required. 

Is there a limit on how many files can be converted? 

There's no limit on how many files can be converted. 

Who can convert TaxCycle client files to ProFile? 

File conversion is available to current year customers only. 

How long will it take to convert my client files to ProFile? 

Usually client files are migrated within an hour, depending on the number of client files uploaded. Customers receive an email from ProFile 
indicating when the conversion is complete. 

What data gets converted during the conversion process? 

The conversion process doesn't produce a complete or accurate prior-year tax return for side-by-side comparison. ProFile converts 
pertinent data to next year's tax return. Conversion isn't a 1:1 transfer of data to reproduce the same tax return for the same year. 

The converted files are a starting point for ‌next year's tax program. The data in the converted file shouldn't be changed in the previous 
year's tax program. 

How's this different from other carry forwards? 

TaxCycle carry forwards work differently from other carry-forwards. A technology is used that allows for faster field mappings and an 
improvement in comparison between TaxCycle and ProFile returns. The result is a faster and more-accurate carry-forward experience. 

How long are my client files saved on Intuit's network? 

Client data is used for conversion purposes only. After the data is converted, a copy is maintained for conversion backup purposes and is 
destroyed after a 30-day period. 

Help ensure you download your files within 30 days of conversion, or you will need to repeat the conversion process. See section 
"Download converted client data" below for the steps in the download process. 
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Why were some of my files not converted? 

There can be several reasons why a TaxCycle client file didn’t convert: 

●​ The file may not have been in the correct folder 
●​ The file may have been locked, or password-protected 
●​ The file may be corrupted 
●​ The file may be missing critical information 

The affected files can be corrected and resubmitted. 

What fields are supported and unsupported? 

Supported fields include: 

●​ All taxpayer information, including taxpayer, spouse, dependents, corporation, etc. 
●​ All important carryover amounts that can be obtained 
●​ 5-year, comparative summary, installments schedule 
●​ Capital cost allowance 
●​ Loss carryover amounts 

Unsupported fields include: 

●​ Quebec TP1 and CO17 tax information 
●​ Amounts that aren't relevant to next-year tax preparation 
●​ Some provincial credit carry forward amounts 

 
Copying TaxCycle client data: 

1.​ Create a new folder under your computer’s C: Drive titled conversion data. This folder may already exist on your C: Drive if you 
have already updated ProFile to version 2025.2.0 or later. 

2.​ Browse to the folder containing the TaxCycle client files to carry forward. You can find this location under Options > Files and 
Folders in your TaxCycle software. 

3.​ Remove any locks or password protection from the files to carry forward. 

4.​ Copy and paste the files to carry forward to the new C:\conversiondata folder you created. 

Submit client data for carry forward: 

1.​ Select the File menu in ProFile. 
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2.​ Select the Submit Client Data for Carry Forward… option under the TaxCycle Carry Forward… menu. 

The Sign In window displays. 

3.​ Sign in to your One Intuit account. 

If you don’t yet have a One Intuit account, select Create an account. 

⚠️Note: You may be prompted to sign in to your ProFile account a second time during 
the conversion process. This is normal behaviour.  

✅A secure connection is established. 

 

The Intuit Competitor Carryforward Wizard displays. 

4.​ Select I am ready to continue. The module selection window displays. 

5.​ Select the module you want from the dropdown menu. This module is for the files 
you want to change for the carry forward process. For example, TaxCycle T1.  

⚠️Note: Each module’s files must be converted separately. It isn't possible to convert T1 
and T2 files at one time. 

6.​ The carry forward wizard reads and displays files matching the selected module 
from the C:/conversiondata folder. 

7.​ Select all files to undergo conversion prior to carry forward. 

 

⚠️Note: only files in the C:/conversiondata folder display for selection. If you don't see a file that should be converted, help ensure it's 
been copied to the folder. 

8.​ Select Next . The selected files begin the conversion. Most jobs will complete within minutes, so you can minimize this window and 
work in ProFile as the upload/conversion takes place. 

ProFile emails a notice that conversion has begun. 

9.​ You can select Cancel Job at any time to cancel the conversion. Conversion may take several minutes depending on file size and the 
number of files being converted. 
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A progress bar displays conversion progress. 

A Conversion complete message displays when the files are successfully converted. 

ProFile converts the TaxCycle files to a ProFile-compatible format. 

ProFile emails you a notice that the conversion is complete. 

10.​Select Close. The Conversion summary window displays. 

11.​Select Open Destination Folder to review the converted files in the TaxCycle folder. 
The location will be C:\Users\[local user]\Documents\My ProFile 
Data\TaxCycle\[module]. 

12.​Select Finish. 

⚠️Note: You can't change the file path for the input (the conversion data folder) or the 
output (My ProFile DataTaxCycle) folders. If you need to save files on a network or other place, you must move them to the place you want 
them after the conversion. 

You may now open the client files in ProFile for further work or electronic filing. 

Review our support article for information on troubleshooting errors and downloading converted client data. 

 

Other Competitors 
 

Carry forward other supplier’s files 

ProFile supports the carry forward of files for the following suppliers: Taxprep, TaxCycle, Cantax, and DTMax. 

Review our full support article on carrying forward other supplier’s returns. 
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Managing Software Integration in ProFile 
 
QuickBooks Desktop Integration 
 

It's easy and convenient to integrate QuickBooks Desktop with ProFile. Select the applicable activity below. 

​
Integrate ProFile and QuickBooks Desktop 

The integration process lets ProFile to display as an integrated application in QuickBooks. 

Review our support article for more information. 

​
Importing data from QuickBooks Desktop to ProFile (T2) 

The import data process imports amounts from QuickBooks Desktop into ProFile.  

Review our support article for more information. 

 

 
39 

 

https://profile.intuit.ca/support/en-ca/help-article/manage-users/integrate-profile-quickbooks/L0SKliSr3_CA_en_CA?uid=mj03s0pc?src=ProFileUserGuide
https://profile.intuit.ca/support/en-ca/help-article/import-export-files/import-data-quickbooks-desktop-profile-t2/L507dUvbD_CA_en_CA?uid=mj03su0h?src=ProFileUserGuide


 

Using ProFile Notification Services 
​
The ProFile notification service provides timely and important information directly to customers. This may include CRA announcements, 
ProFile releases and patches, or critical issues. 
 
Start-Up Notifications 
 
Start-Up notifications display when ProFile starts. They are often urgent 
messages that affect most or all Preparers. They may include reminders of recent 
software updates, CRA changes, or notices of service interruptions.​
 
ProFile in-application Notification Centre 

The in-application Notification Centre displays within the ProFile application. It 
lists recent notifications in the sequence they arrive. Each can be deleted if the 
information is no longer relevant to the Preparer.  Preparers can also turn the 
in-application Notification Centre to Off status to no longer see notifications in 
the application. 

 

Information Call-out 

The Information Call-out highlights general, non-emergency information for 
ProFile customers. The call-out displays temporarily, then removes itself from 
view. 
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Electronic Signatures 
 

Using Intuit Sign, Adobe Sign and DocuSign 

Electronic signatures (or "eSignatures") are a new way to ask clients for signatures and other inputs on forms and documents in ProFile. 
ProFile users can track which requests have been completed and which are still outstanding in one convenient dashboard after requests 
have been sent to your customers. 

Intuit has three products that let you request signatures and other inputs directly from ProFile. You don't have to track individual emails or 
files. These products are Intuit Sign, Adobe Sign, and DocuSign. Intuit Sign is Intuit's own electronic signature solution. Adobe Sign and 
DocuSign are both products that are sold by other companies.  Separate fees may apply, and a paid ProFile license is required for all 3 
solutions. Find out more about setting up and using Adobe Sign and DocuSign. 

Intuit Sign requires a separate license that can be purchased along with your ProFile license. Learn more about purchasing and setting up 
Intuit Sign.  
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Using the Client Explorer Database in ProFile 
 
Setting Client Explorer as the ProFile Database 
 
ProFile users can set and use Client Explorer as the database when preparing client returns. The database allows you to use filters and 
queries to narrow down what you see amongst your clients, as well as perform certain batch actions, such as carry forward, EFILE, or print. 
 
Setting Client Explorer as database: 
 

1.​ Open ProFile. 

2.​ Select the Database option from the Options dropdown menu. 

The Database/Client Explorer Options window displays. 

3.​ Select the Use Client Explorer option, the Client Explorer menu 
displays. 

4.​ Select the Personal Server or Shared Server option. 

5.​ Select the folder path if a shared server is being used. 

6.​ Select Setup Wizard to create a shared server. 

7.​ Select Advanced to explore additional options, including the 
handling of clients with no SIN. 

8.​ Select OK when completed. 

✅The Client Explorer is set as the database option. 
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Using Filters in Client Explorer 
 
By default, the Client Explorer displays all files regardless of the type of return, taxation year, or status. By default, the Client Explorer shows 
all files, no matter what type of return, tax year, or status. Filters let only those files that meet the requirements set by the Preparers show up. 
These include files that have already been filed or files that are still missing. 
 
Viewing Filter options: 
 

1.​ Select the Client Explorer option from the Goto dropdown menu. 

A list of all available returns for clients displays. 

2.​ Select Filter. 

The filter window displays at the bottom of the ProFile program. The filter pane contains all filter options for clients and their returns.​
 

Options for filtering 
display in individual tabs 
and include: 

●​ Available tax years 
●​ Modules (for 

example, T1, T2, 
etc.) 

●​ Client Status 
●​ EFILE status  
●​ SEND status 
●​ EVENT 
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Using Filters in Client Explorer: T1 EFILE Filtering Example: 
 
Example: Filter for only T1 returns that are completed and ready to EFILE. 
 

1.​ Select the Client Explorer option from the Goto dropdown menu. 

2.​ Select Filter. The filter window displays at the bottom of the window.​
  

Selecting forms: 
 

1.​ Select the checkbox on the T1 tab and clear the other module tabs by unchecking them. This displays only T1 forms. 

2.​ Select the checkbox for the current year (for example, 2025) on the T1 tab and clear the checkboxes for all other years by 
unchecking them. This displays only the 2025 tax year.  

3.​ Select the checkbox for Carry Forward in the Client Status column and clear the other statuses by unchecking them. This displays 
only those returns in the carry forward state. 

4.​ Select the checkbox for Eligible in the T1 EFILE Status column and clear the other statuses by unchecking them. This displays only 
those returns in the “eligible” state. 

⚠️Tip: To quickly select/de-select items, right-click on the section (example: Years) and select either Select All or Clear All.​
 

Applying filters: 

 
1.​ Select Apply Filters.  

2.​ Select the All tab in the Client view.  

✅The current year T1 files that are eligible for EFILE display. 
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Using Queries in Client Explorer 
 
⚠️Note: A query applies only to returns of a single type (for example, 2025 T1 returns). The Client Explorer's search function lets 
Preparers create a list of files with specific values for printing or to include on a report. Queries can also select data to export or to select 
files that require mailing labels. 

The query function filters the client list to compare fields and display the matching client files. A query can be applied for any field in the 
client file, including client city, debt level, return status, or age. 

Query example: 

A Preparer wants to choose all clients who were born before January 1, 1956, but after December 31, 1956. These clients are the ones who 
turned 69 in 2002. 

​
Running a query: 

1.​ Set Client Explorer as the database option in ProFile.  

2.​ Open Client Explorer in ProFile. A list of clients displays. 

3.​ Select Filter, a list of options displays. 

4.​ Select the module to be queried (for example, T1) and tax year to be 
queried (for example, 2024). 

5.​ Select Advanced, the Advanced Filters window displays.  

6.​ Select New. The Advanced Filters window expands to display Add 
and three Conditions for queries. 

7.​ Select Add. The Add Condition window will display. 

 
⚠️Note: If you need information from your returns that isn’t found in the 
default Field Name options, you can pull information from any line of a 
return to query for deeper insights and reporting.  For more information, please refer to our support article. 
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Setting conditions for queries 
 
In this example, we'll be querying client invoices for amounts no greater 
than $10,000. 
 

1.​ Select the dropdown menu in the Condition field of the Add 
Condition window. A list of conditions will display. 

2.​ Complete the Field Name, Condition, and Compare to fields. 

3.​ Repeat Steps 1 and 2 if you require additional conditions. 

4.​ When the query is completed, Select Ok. 

5.​ A window appears asking if you’d like to save the query.  If you will 
use it again, select Yes. 

6.​ You are then prompted to name the query.  Select OK.In the 
Client Explorer, select Apply Filters.  

✅The query runs and displays results. 

⚠️Note:If your query uses the date field, make sure your computer’s date and time are set to YYYY/MM/DD. This matches the format 
CRA uses and helps you avoid error messages. 

For more detailed instructions on queries, review our support article. 
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Printing Reports in Client Explorer 
 
The Client Explorer’s report function allows Preparers to print data from ProFile 
returns. 

⚠️Note: A query applies only to returns of a single type (for example, 2025 T1 
returns).​
 

Setting Client Explorer Report Parameters and Data: 
 

1.​ Open Client Explorer in ProFile. 

2.​ Filter returns by the necessary parameters (for example, tax year, status, etc.). 

3.​ Select the Select All option under the Database dropdown menu.  

4.​ Select the Print Report option under the Database dropdown menu. The 
Create Report window displays. 

5.​ Select Options, the Report Options window displays.  

6.​ Select the Fields tab.  

The options display for creating a report, including column, rows, titles, and 
organization of report content. 

7.​ Select the data to be listed under each report heading.​
 

⚠️Tip: You can also insert field codes from any line of a return by copying them 
into your report, if they already exist in your query. Delete the {} on either end of the 
field's code so the text turns black for the field code to be applied. 

Running a Client Explorer report: 
 

1.​ Select Save in the Report Options window. The report's parameters are 
saved. 

2.​ Select OK. The Report Options window closes. 
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3.​ Select the Print option from the Create Report window. 

The report compiles, and is sent to the designated printer. 
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Using Mailing Labels in Client Explorer 
 
ProFile’s Client Explorer provides Preparers with a simple and convenient method for 
printing mailing labels.​
​
Choosing a mailing label: 

1.​ Select the Setup Mailing Labels… option from the File dropdown menu. 

The Label Selection window displays. 

2.​ Select the return type (for example, T1) and tax year (for example, 2025) from 
the tab menu. 

3.​ Select the Label Type from the dropdown menu.​
 

Creating a new mailing label: 

1.​ Select New Label. The Label Details fields activate and populate.  

2.​ Enter the specific measurements for the label in the Label Details fields.  

3.​ Save the name of the new label in the Label Details field (for example, T1 2025 
Label). 

4.​ Select OK. The label saves and the window closes. 
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Printing mailing labels: 

1.​ Open the Client Explorer database in ProFile. 

2.​ Select the client for which the label will apply. 

3.​ Select the Print Mailing Labels option under the Database dropdown menu. The Print 
Labels window displays. 

4.​ Select the number of labels to print under the Copies field. 

5.​ Select the checkbox for Print only one label for coupled return? If required. 

6.​ Select OK. The label(s) print. 

 

⚠️Tip: You can batch-print clients by filtering for the module and tax year.  After applying 
filters, select all clients, and continue with step 3 in the above instructions. 
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Batch EFILE in Client Explorer 
 

ProFile users can build and EFILE files to CRA for multiple clients and returns at once. 
Doing so creates a “batch”, a set of individual and client files ready for EFILE, which 
ProFile sends to CRA or RQ all at once. ​
​
⚠️Note: Batch EFILE is only available for T1, TP1, and FX modules. 

Batch and transmit files: 

1.​ Open Client Explorer in ProFile. 

2.​ Select the type of EFILE operation to perform from the dropdown menu. ProFile 
filters the list of files to reflect only those with the selected status (for example, 
T1 - EFILE Eligible). 

The list of eligible files displays. 

3.​ Select the files to include in the batch transition. 

4.​ Right-click on the selected files and select the Build EFILE File… option from 
the menu.  Alternatively select Build EFILE… from the left Action menu. 

The build window displays. 

5.​ If necessary, specify the type of EFILE file to create, or the agency, data type, or 
slip type. 

6.​ Select OK. 

The EFILE files build. The build status of each return displays as Successful or Failed.  

7.​ Select the red X to display the issue with the Failed return. Select Transmit now. The files are transmitted to the CRA. You can also 
select the Transmit later option. 

⚠️Note: CRA stipulates a two-second pause between the EFILE of each file. This may result in a slower-than-expected process to EFILE 
for customers with many files in a batch. 

⚠️Note: A single file with client names and confirmation codes is generated and may be difficult to find specific clients if you have 
multiple filing batches.  Ensure you come up with a process to identify which clients are in each batch. 
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Batch Printing Forms in Client Explorer 
 

It's easy to print pre-configured print sets for multiple clients at the same time.  

Printing forms for a group of clients: 

1.​ Open Client Explorer. 

2.​ Select the designation for clients in the dropdown list (for example, T1 
- EFILE Eligible). The clients matching the designation displays. 

3.​ Select the clients to batch print. 

4.​ Select the Print files… option from the Actions menu. 

ProFile automatically selects the forms to print for each file based on the print 
job and print setting options configured in the Form selection window. For 
example, ProFile detects that each client selected will receive an “overdue 
invoice” letter. 

✅The files print. 

Printing the same forms from each file: 

You can print the same form for multiple clients at once. For example, a ProFile user may want to print a form for each client so that it can be 
mailed for the client’s signature. 

⚠️Note: When printing forms from multiple clients at the same time, you can print only forms from files of the same module and year. 

Printing forms: 

1.​ Select the designation for clients in the dropdown list (for example, T1 - EFILE 
Eligible). The clients matching the designation displays.  Alternatively, use the 
Filter option to narrow down the scope of clients you’d like displayed. 

2.​ Right-click in the client list and choose the Select All option from the menu. 

All forms are selected. 

3.​ Select the Print Forms in File… option from the Database dropdown menu. 

The Print Selected Forms window displays.  
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4.​ Enter the name of the form to print (for example, T2038). 

⚠️Note: To print several forms, enter them all with a colon as a divider between each form (for example, T2038:T2036). 

5.​ Select OK. The forms print.  
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Using Templates in ProFile 
​
Templates allow Preparers to save time and effort by creating commonly used communications that can be sent to one or more clients.​
 

Selecting templates: 

1.​ Select the Templates option from the Options dropdown 
menu. 

The Template Editor window displays.​
 

Using templates ​
​
The template list includes the most common communications that 
Preparers need. These include engagement letters, client 
invoices, and payment emails. 

Both French and English templates are provided.  

1.​ Double-click any template. The template opens in the 
editor pane. 

2.​ Edit the template required and save for future use or additional editing and customization. 

⚠️Tip: Press F1 on any field in the Template Editor to learn more about its function.​
​
For more info, check out our article on using file templates in ProFile.  
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Setting Pricing in ProFile 
 
ProFile pricing feature provides a convenient method for Preparers to set costs and bill clients for services.  
 
Getting started with pricing: 
 

1.​ Select the Pricing… option from the Options dropdown menu. 

The Pricing Schedule window displays.  

Pricing options: 

1.​ Select the module for which to set pricing options for (for example, T1). The 
current and previous tax year pricing displays. 

2.​ Enter information for the GST registration number, invoice number, and 
GST/HST/PST rate. 

3.​ Select the invoice type: Detailed, or Brief. 

4.​ Select how the client will be invoiced: by Schedule or Hour. 

5.​ Insert costs for services (for example, basic charge, capital gains, etc.) 

6.​ Select OK to save the pricing information.  

⚠️Tip: At the bottom of the list of forms, there's a line to enter your Hourly rate. This rate can be customized for different users if you use 
Options Packages. 

Carry forward pricing: 

ProFile lets Preparers carry forward pricing from previous tax years to the current tax year. 

1.​ Select the previous tax year (for example, 2024 T1/TP1). Review the pricing for services.  

2.​ If the same pricing is to apply to the current tax year, select Carry Forward. 

3.​ Select OK when asked to carry forward prices to the current tax year.  

✅The previous tax year pricing displays in the current tax year. It can be changed at any time. 
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Using Form Explorer in ProFile​
 
The Form Explorer feature allows Preparers to locate individual forms, lines, and details within a client’s return. In addition, Preparers can 
print forms from the Form Explorer and determine when it was last updated. 
 
Starting the Form Explorer 

1.​ Open ProFile. 

2.​ Open a return (for example, a T1).  

3.​ Select the Form Explorer option from the Goto 
dropdown menu. 

The Form Explorer opens. The client’s name displays in 
the top-left corner. 

Using the Form Explorer 

1.​ Select a view option from the top-right menu 
options. View options include: 

●​ List - displays all forms in the return 

●​ Detail - displays details and/or status about all 
forms in the return 

●​ Key - searches the return for keywords (for 
example, RRSP) 

●​ Line - displays each line in every form in the 
return. 

⚠️Tip: Hover over ‌each form to see a full title. 

2.​ Double-click any form listed in the Forms Explorer. 
The form opens in ProFile. Select Print to print any 
form from the Form Explorer. 
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Using Options in ProFile​
 
Setting Environment Options in ProFile 
​
ProFile users can set options for their ProFile working environment. This includes PDF settings, form settings, reminders, security, and more. 
Select the Environment… option from the Options dropdown menu in ProFile.​
​
The following list includes the most-commonly used options: 
Edit tab 

The Edit tab includes options for common tasks, such as allowing predictive typing, date stamping, SIN validation, and capitalization. 

Display tab 

The Display tab includes options for the display of ProFile, including font scaling, tab icons, and page breaks. 

File tab 

The File tab includes options for setting file directories, managing recently used files, and auto-saving files. 

Preparer tab 

The Preparer tab allows Preparers to insert their personal and firm information, including RepID, Group ID, and initials. 

Discounter tab 

The Discounter tab allows a discounter to insert their personal and firm information, including Discounter Registration Number. 

Trustee tab 

The Trustee tab allows trustees to insert their personal and firm information. 

Audit tab 

The Audit tab allows Preparers to set audit ‌or edit error styles. This helps establish standards to prevent a return from being prematurely 
filed.  

System tab 

The System tab includes options for setting shared folders, checking for software updates, and using online features. 

PDF tab 

The PDF tab allows Preparers specify PDF characteristics for printed returns, PDF archive directories, and PDF security. 
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​
Using File Pathing in ProFile 
 
About file pathing 
ProFile users can set where their client’s returns are stored. The file path can be 
changed or locked to prevent deletion or copying. 

​
Managing file paths: 

1.​ Select the Environment… option from the Options dropdown menu. 

2.​ Select the File tab in the Environment Options window. 

Files paths display under the File Directories section of the window. 

Files in the file path display in the corresponding directory in Explorer.  

3.​ Select the Lock checkbox to lock the file path to prevent any changes. The 
lock feature will default back to this file directory but can be changed even 
when locked.​
 

Changing file path: 

1.​ Select the file directory to change. 

2.​ Select Show path . 

The Browse window explorer displays. 

3.​ Select a new location from the Browse window. Select OK. 
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Using Module Options in ProFile 
 
Module options overview 
ProFile customers can edit options for each tax module (for example, T1, T2, etc.) for which they are preparing returns.​
​
Select the Module… option from the Options dropdown menu. 

​
Setting module options 

Each module tab includes an active down arrow. Select the arrow to 
display the available tax years for the module display.​
 

Module Option Tabs 

General tab 

The General tab includes options for carry-forward, individual forms, 
access, and more. 

Data Locking tab 

The Data Locking tab allows Preparers to set the criteria for locking 
a file. For example, if the file carries forward or is transmitted. 

Variance tab 

The Variance tab lets you set the minimum amount of money you 
can make. You can choose between dollars or percentages. 

Disclaimer tab 

The Disclaimer tab includes the option to include a standard 
disclaimer on all prepared forms. 

T1/TP1 Review tab 

The T1/TP1 Review tab allows the setting of the Variance Thresholds, using the criteria of Dollar and/or Percentage. 
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Using Options Packages in ProFile 
 
An options package is a file that saves customized ProFile settings. These can include office details, printing options, database settings, and 
template and module settings. ​
​
Creating an options package means that your ProFile settings can be used by you or by others without having to recreate any preferences. 
This can be extremely helpful if you have staff to ensure they have customized access to what they need in their ProFile setup. 

​
How do I use the option package? 

An options package can be used a few different ways:  

●​ Saved on a shared network/server where everyone has access to it 
●​ Saved on a terminal server where everyone has access to it 
●​ Saved locally to a single computer that isn't on a shared network/server 

Depending on which use is selected, multiple customers can work with ProFile in the same consistent manner, or an individual user can 
work with ProFile in a manner specific to themselves.  

 

Types of options packages​
​
There are three types of options packages in Profile: Individual, shared, or custom.​
​
Individual options packages save on an individual computer and are loaded when ProFile launches. ​
​
Shared options packages save to a network/shared server where one or more individual computers have access to the package. This is the 
ideal option if you are using a network environment, Client Server, or Terminal Server environment. ​
​
Custom options let the same ProFile options work even if a computer isn't connected to a network, server, or terminal server. A Profile 
Customer creates custom options packages in different locations and instructs ProFile which to use.  
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Creating an Options Package in ProFile 
 

1.​ Open ProFile.  

2.​ Select Options Administration… from the Options menu, the Options 
Administration window displays. 

3.​ Set the necessary options for the package (Any modifications to items in 
the Options or EFILE Options are available to customize. For example, 
template use, pricing, database, etc.), these selections will become the 
settings in the new options package.  

4.​ Select the options package type (1, 2, 3 or 4).  

5.​ Check the option Include Preparer and discounter name with Option 
packages, if applicable.  

6.​ Check the option Prompt to save changes, if applicable. This feature only 
works with package types 2, 3, and 4. Selecting the option prompts the 
user to save any changes made to an options package when closing 
ProFile.  

⚠️Note: Any changes made to an options package prior to ProFile being 
closed aren't saved if the Prompt to save changes feature isn't activated. 
Customers must explicitly use the Save function to save any changes or they will 
be lost when closing Profile.  

7.​ Select New.  

The New Settings window displays.  

8.​ Enter the name of the new options package. 

9.​ Select OK.  

✅The new options package file saves to the designated location and displays in the Options Packages list. 

⚠️Tip: The naming convention of Options packages can vary based on role, individual, type of return, etc. Deciding how your firm is 
structured and the roles/responsibilities of team members will determine how you set this up. 
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Managing Options Packages in ProFile 
 
Options package management includes several tasks that can be undertaken, including:​
 

●​ Creating a new options package 
●​ Loading an options package 
●​ Updating an existing options package 
●​ Deleting an options package 
●​ Transferring an existing options package 

 

Related Articles 

Review our support article to learn more about how to manage option packages. 
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Using Custom Option Packages in ProFile 
​
A computer that is using an options package on a network/server/terminal server will lose access to it if the computer disconnects from the 
network/server/terminal server. ​
​
However, ProFile can be set to access an alternate local options package (or packages) on the individual computer’s hard drive as a 
substitute to the network/server/terminal server options package. ProFile will first search for the designated options package on the 
network/server/terminal server. If that options package isn't available, ProFile will search for the next options package on the list. ​
​
⚠️Note: ProFile doesn't synchronize changes between options packages. Any changes to a local options package while disconnected 
from the network/server/terminal server aren't saved in the network/server/terminal server options package. ​
 

Managing files in multiple options packages​
 

When the computer connects to a network or server, use the options package stored there. 

When the laptop disconnects from the network/server/terminal server, users can specify an options package stored locally on the laptop 
itself.  

However, be aware that by having two different sets of options, you are using two different databases. Files created or changed when you 
disconnect from the network/server/terminal server won't be listed in the database stored on the network/server/terminal server. ​
 

Creating and assigning multiple options packages​
 

ProFile users who will disconnect at some future time from a network/server/terminal server and continue working will need to create at 
least two options packages: one for connected network/server/terminal server use and one for when disconnected from the 
network/server/terminal server. This allows the disconnected work to use the same options package settings as that on the 
network/server/terminal server.​
 

Related articles 

Review our support article to understand more about using multiple options packages. 

Password Protecting Options and Options Packages in ProFile 
 

Any Options Package can be password-protected. This prevents unauthorized users or other Preparers from altering the options package. 
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This feature protects both the computer options and the options package.​
​
Password protecting options packages: 

1.​ Select the Options password… item from the Options dropdown menu.  

The Set Options/Delete Password window displays. 

2.​ Enter a password in the Password: field of the New password section.  

3.​ Enter the same password again in the Confirm: field.  

4.​ Select OK.  

The password is saved and the options package file is protected from changes and 
deletion. A prompt requesting the password displays any time changes are made to the 
settings.  

⚠️Note: This password applies to Options packages only. It isn’t an EFILE password. 
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Managing Printing in ProFile 
 
Print Setup in ProFile 
 

1.​ Select the Print Setup… option from the File dropdown menu. 

The Print Setup window displays. 

2.​ Select the correct year for the module, and the available print settings display. 

Applicable forms, jackets, letters, and more that are applicable to the module are listed 
under the Category column. 

3.​ Select each available category and set/approve the margin settings, font scaling, 
position, duplexing, and other printing values. 

4.​ Select OK to save the print setup settings. 
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Using Print Sets in ProFile 
 
Form selection overview 
The Form Selection menu allows Preparers to set print options for forms for each module as well as different print jobs. 

 

Selecting templates: 

1.​ Select the Form Selection option from the Options 
dropdown. 

The Form Selection menu displays. 

Using form selection 

A list of print options displays in the Form Selection menu. 

This list includes the ability to set the print options for File, 
Client, and CRA. Individual forms are listed, including the 
option for setting language. 

Toggle to any box to activate a print option for the form. 

At any time, you can restore your defaults by selecting Set 
Defaults. 

⚠️Tip: ‌Select F1 on any field to learn more about it.  

Items in a print set can be re-ordered by dragging and 
dropping them into the order you’d like them to appear. 

You can change the status of a return after printing. 

There are 2 additional print set names you can use to 
customize any other set types you may require in each module 
as well. 

If the print set settings will be the same in the next year, you can use Carry forward. 
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Printing Different Copies 
 

ProFile users can set the print job options for returns and forms. 

Setting print job options: 

1.​ Open the return in ProFile. 

2.​ Select the Print… option from the File dropdown menu. 

The Print Selection window displays. 

3.​ The Print Job section in the top-left corner of the window displays 
the print job types (for example, T1 Paper). 

⚠️Note: The province of residency selected on the return determines 
the available print jobs. For example, setting Quebec as the province of 
residency displays TP1 print jobs. 

4.​ Set the print job settings. 

​
Advanced and simplified settings: 

1.​ Select Advanced in the bottom-left corner, and the advanced print 
job options display. 

2.​ To return to the simplified view, select Simplified. 

​
Printing jobs: 

1.​ Select Set Defaults to set the selected print job options as the default. 

2.​ Select Print. 
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Printing to PDF/Email in ProFile 
​
Setting print to PDF options: 

1.​ Open the return. 

2.​ Select the Print/Email PDF… option from the File dropdown menu. 

The Print Selection window displays. 

3.​ Several options for PDF printing are available, including: 

●​ Setting the print job type in the top-left menu (Print Job) 
●​ Setting print job options under the Options section 
●​ Setting the print job resolution under the Resolution dropdown menu 
●​ Emailing the print job to an email address entered in the email field 

4.​ Set the necessary options for PDF printing. 

​
Previewing the PDF: 

1.​ Select Preview, a preview copy of the PDF displays. 

2.​ Review the form for any issues or needed corrections. 

Advanced menu option: 

1.​ Select Advanced. 

✅The window expands to display the advanced print to PDF options. 

Building the PDF: 

1.​ If there's no email listed in the Email Address field Build PDF activates. 

2.​ Select Build the PDF. The PDF is created and the path of the file name 
displays. 

3.​ Select OK.  

✅The build of the PDF completes. 
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Email the PDF: 

1.​ If there is an email listed in the Email Address field, Email activates. 

2.​ Select Email.  The file is sent to the designated folder and a PDF is 
generated. 

3.​ Select Open PDF folder in the window to find where the file is located. 

4.​ Attach the file to an email. 

 

Related Articles: 

Review our support article to learn more about the Archive PDF functionality. 
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Setting up Duplex Printing in ProFile 
 
Duplex printing allows Preparers to print returns on both sides of a single sheet of 
paper. 

Setting Duplex Printing Options: 

1.​ Open ProFile. 

2.​ Select File, and then Print Setup. The Print Setup window displays.  

3.​ Select the desired tax year and module from the tab menu (for example, 1. 
2025 T1/TP1). 

A list displays below the tabs, detailing available forms, letters, and more. 

4.​ Uncheck the Always use Default Windows Printer above the Category 
heading. 

5.​ Select the first item listed under the Category heading (for example, T1 jacket). 

6.​ Select Properties under the Printer heading. 

The Print properties window displays. 

7.​ Some printer manufacturers may require you to select the duplex printing option 
from the options presented. Adjust settings as required based on your printer.  

8.​ Select OK. In the Print Setup window, check the Use printer duplex settings 
box. This activates the duplex settings. Repeat the duplex printing configuration 
for each applicable option under the Category list (for example, T1 forms, and 
Letters) 
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Printing Slips in ProFile 
 
When sending a slip to print from ProFile, the printout may be cut off, print a blank page, or not print at all. This is due to the slips' official 
size conflicting with the printer settings. ​
​
Changing default slip print settings: 

1.​ Select the Print Slips Setup… option from the File dropdown 
menu. The Slips Print Setup window displays. 

2.​ Select the tax year from the module dropdown menu in the top bar. 

3.​ Select the slip type from the tab menu (for example, T4PS). Update 
and apply the necessary print slip settings.  

4.​ Select Test to test print the settings. 

5.​ Select OK to save the settings. 

Printing the slip: 

There are four printing options available under the File dropdown menu: 

●​ Print… 
●​ Print / Email PDF… 
●​ Print Slips… 
●​ Print Slips / PDF 

Each option opens a print settings window. Update and apply the 
necessary print slip settings.  

Select Print or Build PDF. The slip prints or builds a PDF file. 

​
Reviewing the printed slip (if PDF printed): 

1.​ Open the generated PDF in the PDF-viewing software (for example, Adobe Acrobat). Ensure that the PDF is set to fit on the page. 

2.​ Select the desired paper size under the Page Setup option.  

3.​ Match the desired paper size under the Printer Properties option.  
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Keyboard Shortcuts in ProFile 
 

If you handle a lot of client files, learning keyboard shortcuts in ProFile can save you time.​
 

Action Shortcut Command 

Attach tape <Ctrl+F8> 
Back to previous form <Alt+F7> 
Carry forward a file <Ctrl+R> 
Clear highlighter <Ctrl+H> 
Clear review mark on field <Ctrl+Alt+0> 
Close current window <Ctrl+F4> 
Copy field <Ctrl+C> 
Correction required mark <Ctrl+Alt+3> 
Create a new file <Ctrl+N> 
Cut field <Ctrl+x> 
Display jump list <Shift+F6> 
Display previous audit message <Shift+F9> 
Ditto key (back apostrophe) 
EFILE this return <Ctrl+F11> 
Instant SEND <Shift+F11> 
End review <Ctrl+E> 
Exit ProFile <Alt+F4> 
Explorer Keyword view <Shift+F7> 
Explorer Line view <Shift+F4> 
Federal/Quebec toggle <Shift+F5> 
File properties <Ctrl+I> 
Form help <Shift+F1> 
Next checklist form <Ctrl+Alt+PgDn> 
Next Edit window form <Ctrl+Tab> 
Next file <Ctrl+F6> 
Next page on form <Ctrl+PgDn> 
Next section on form <Alt+PgDn> 
Non-zero T1 summary <Ctrl+F10> 
Open an existing file <Ctrl+O> 
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Action Shortcut Command 

Open form in new window <Ctrl+Alt+F6> 
Open the Tape dialog box. <=> 
Override format <Ctrl+F2> 
Partner sign-off <Ctrl+Alt+2> 
Paste field <Ctrl+V> 
Pause / start timer <Ctrl+T> 
Preparer sign-off <Ctrl+Alt+1> 
Previous checklist form <Ctrl+Alt+PgUp> 
Previous Edit window form <Ctrl+Shift+Tab>* 
Previous page on form <Ctrl+PgUp> 
Previous section on form <Alt+PgUp> 
Print file(s) <Ctrl+P> 
Question review mark <Ctrl+Alt+4> 
Quick-print audit messages <Alt+F9> 
Quick-print T1 summary <Ctrl+Alt+F10> 
Quick-print T183 form <Alt+F11> 
Quick-print tax summary <Alt+F10> 
Save the file <Ctrl+S> 
Show/hide auditor <Ctrl+F9> 
Snapshot/Variance <Alt+F8> 
Switch to family member <Alt+F5> 
T1, T2, T3 jacket <Ctrl+J> 
Toggle T1/TP1 <Shift+F5> 
Toggle T2/AT1 RSI <Ctrl+F5> 
Top of next slip <Ctrl+Enter> 
Top of previous slip <Ctrl+Shift+Enter> 
ProFile Help F1 
Override F2 
Client Explorer F3 
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Using Multiple Windows in ProFile 
 

The multiple windows feature allows the Preparer to view two ProFile returns, each in its own window. This is a useful feature when the 
Preparer needs to see two returns side-by-side for clarity or comparison. For example, a Preparer can open two T1 returns and view them at 
the same time, rather than having to toggle back-and-forth between them. 

Opening multiple windows outside ProFile Using Icons: 

1.​ Open two or more returns in ProFile. 

2.​ Select the tile window icon  ‌. 

The returns open in individual windows on the desktop. 

3.​ Select the launch window icon  in each window to open the return on a separate screen. 

4.​ Select the return window icon  to bring the return back into ProFile. 

  

Opening multiple windows inside ProFile 

Open two or more returns in ProFile. 

1.​ Select the appropriate option from the Window dropdown 
menu. These include: 

●​ Tile Horizontally: The returns are stacked on top of each 
other 

●​ Tile Vertically: The returns are stacked beside each other 
●​ Cascade: The returns each open in a smaller window that 

can be manipulated 
●​ Launch Current Window: the current return opens in a 

new window outside ProFile 
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Toggling between multiple open returns: 

1.​ Select the Window dropdown menu. 

Any open returns display at the bottom of the menu. The active window is bolded. 

2.​ Select any return listed in the menu to display it. 

⚠️Note: You can't open more than 1 T2 return if you are using Corporate Linking as it'll break the link. 
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Understanding Colours in Data Fields 
 

You may notice several text fonts or fields have different colours as you prepare returns.  Understanding those colours will help you determine where 
information is coming from and what is happening within the return.   

 

Black Text - This colour text symbolizes data that has been or needs to be manually entered.  It can also be referred to as free-form text. 

Blue Text - Data that flows from another part of the return or is calculated will appear as blue text.  Depending on which module or return you’re 
completing, that information can come from a linked return, form or schedule.  Double-clicking on the field will take you to the source. 

Green Text - This field is locked and cannot be altered.  This information could be stored within your settings, such as Preparer or EFILE information.  It can 
also be information within a return that can’t be altered such as a Business Number on the source form.  Double-clicking on the field may take you to the 
source, if available. 

Red Text  - Any override of information will turn the text red.  Ensure the override was not an error.  A Diamond symbol will also show to the right of the 
data field. 

Purple Text - Any information that has been carried forward appears in this colour. 

Yellow Highlighted Fields - These are a visual indicator that something has a potential action required or information that should be reviewed.  When you 
hover over a yellow field, an additional information box appears with more information. 

Green Highlighted Fields - Calls attention to fields that need additional review.  Information related to the field is obtained by hovering over the field.  It can 
also symbolize additional attachments such as tapes, memos, and documents that are attached to the field.  
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Using Review Marks in ProFile 
Preparers assign review marks while undertaking returns in ProFile. Preparers use review marks to show if the field's information is correct 
and checked. They also use review marks to show if the field needs more information or data from a client.  

⚠️Note: If you have staff within your firm, review marks can be used by Reviewers, Team Leads, or Partners to help facilitate internal 
collaboration. 

Review marks appear on the ProFile top toolbar menu as red icons: Checkmarks, an X, and a question mark.  

Types of review marks 

There are four types of review marks available in ProFile: 

●​ Preparer sign-off: The Preparer of the return must provide sign-off 
●​ Partner sign-off: The partner of the return must provide sign-off and has a little tail at the top of checkmark 
●​ Correction required: The field requires a correction (amount, etc.) 
●​ Question: The data provided in the field prompts a question or clarification 

Using review marks 

1.​ Open the return that requires review marks. 

2.​ Select the appropriate review mark from the top toolbar menu. The mouse pointer changes to an arrow 
with the corresponding mark attached.  

3.​ Select the appropriate field in the return to apply the review mark. The review mark appears over the 
black status box. 

4.​ Save the return.  

✅The added review marks are retained in the return until addressed/removed by the Preparer.  

⚠️Tip: Use memos in addition to review marks for further clarification.  For example, if there's a question, use a memo to attach a 
question in that field.   
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Attaching Tapes in ProFile 
​
Using ProFile, Preparers can attach tapes to fields. The Attach Tape feature functions much like an adding machine that performs and 
records calculations.  
 
Tape options are managed in the Options -> Environment… -> Edit tab in ProFile. 
 
Attaching tape: 
 

1.​ Open a file in ProFile. 

2.​ Select field to attach a tape.  

3.​ Right-click, and select the Attach Tape option from the menu. 

The Tape window displays. 

4.​ Enter a description (for example, Shirts) into the left-side field of the table. 

5.​ Enter a value (for example, $500.00) into the right-side field of the table. 

6.​ Select the <Tab> key to cycle through the fields and start a new row.  

7.​ When all fields are completed, select the <Enter> key. The total is calculated and inserted into the selected field on the form. 

✅The background color of the field changes to green when a field has a tape ​
attached. 

⚠️Note: When you select Post, the total will show on the line. If you leave it unchecked, the tape calculations are attached, but the value 
stays at $0 until you post the tape. The field remains highlighted to show a tape is attached. 

Once a tape has been attached, you may hover over the field to see the details of the tape.  All 
fields will be highlighted in green. 
 
⚠️Note: Only the sum of a tape—not individual entry details—are printed or transmitted with 
the tax return data. The details and descriptions are for Preparer reference only.  
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Clearing an Attached Tape​
 

1.​ Open the file with the attached tape in ProFile. 

2.​ Select the field from which the attached tape is to be cleared.  

3.​ Right-click, and select the Attach Tape option from the menu. 

The Tape window displays. 

4.​ Select Clear, the tape will clear. 

5.​ Select OK. The window closes and the tape clears from the field. 

​
Copying a Tape from One Field to Another 
 

1.​ Open the file with the attached tape in ProFile. 

2.​ Select the field with a tape attached. 

3.​ Right-click, and select the Copy Memo/Tape option from the menu.  

4.​ Select the destination field for the copied tape. 

5.​ Right-click the destination field and select the Paste Memo/Tape option from the 
menu. 

The tape attaches to the destination field. 

 
⚠️Note: When pasting a tape to a destination field, the value of the destination field will 
be set to the total in the tape. If that destination field is also a calculated field, ProFile sets the 
override flag on that field. 
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Attaching Memos in ProFile 
 

Preparers can attach memos to fields on all ProFile forms. Memos are short notes and reminders, 
like sticky notes. Memos are useful for leaving notes or reminders for partners or reviewers to 
read, and can also facilitate collaboration within the firm.  Memos can also be used in conjunction 
with review marks or tapes. 

⚠️Note: Memos don’t print or transmit over the internet with a tax return file, or impact the 
calculation of a return.  

Memo text displays in a pop-up window when hovering over a field with a memo.  

Fields with attached memos also appear in the Memo and Summary tabs in the Active Auditor. ​
 

Attaching a memo 

1.​ Right-click in a field and select the Attach memo option from the menu.  

The Memo window displays. 

2.​ Enter the memo content into the text field in the Memo window. 

3.​ You may Insert Date Stamp if you wish to track when memos are posted, or if additional comments may be added. 

4.​ If review marks are required at this stage, they may be added. 

5.​ Select OK. 

The memo is attached. The color background of the field changes to green. 

Clearing a memo 
 

1.​ Right-click in a memo field and select the Attach memo option from the menu.  

2.​ Select Clear. 

3.​ Select OK. 

✅The memo text clears from the form field. 
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Using Intuitive Copy in ProFile 
 

The copy and paste function allows Preparers to save time when it's necessary to create a copy of a business statement already in use. 

For example, a Preparer may be completing business statements for non-spousal partners in a T1 return. When using copy and paste, it'sn't 
necessary to re-enter the same business data in both files.  

Using Form copy and paste: 

1.​ Open ProFile. 

2.​ Complete the necessary statement in the client file.  

3.​ Select the Copy Form option from the Edit dropdown menu. 

4.​ Open the data file for the partner.  

5.​ Open a blank copy of the same statement in the partner’s file. 

6.​ Select the Paste Form option from the Edit dropdown menu. The blank form populates. 

7.​ Edit/complete the populated form for this client.  

ProFile business statements have a section for partner information. This includes the partner's name, social security number, and how much 
of the partnership's money is shared. Intuitive copy and paste lets this information be copied quickly into each partner form. 

1.​ Finalize all business statement data. 

2.​ Select the Intuitive copy option from the Edit dropdown menu. The statement’s data copies. 

3.​ Open the business statement in the partner’s file. 

4.​ Select the Intuitive paste option from the Edit dropdown menu, the date is copied into the partner’s statement. 

⚠️Note: ProFile automatically adjusts all amounts and partner details. Attached memos and tapes also copy to the partner’s business 
statement. 
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Attaching Hyperdocs in ProFile 
 

ProFile's HyperDocs feature lets you attach many documents in any format to a 
form or field in a return. Certain documents may be required with the Provincial 
portion of a tax return, such as the CO-17.  Other times, you may want to attach 
documentation for your own records. 

⚠️Note: HyperDocs are stored with the Preparer files but aren't included with 
T1 EFILE or TP1 NETFILE transmissions.  Hyperdocs is available in the T1, TP1, T2, 
and CO-17 modules. 

Attaching HyperDocs: 

1.​ Open a form in ProFile. 

2.​ Select the field to attach a HyperDoc. 

3.​ Select the HyperDocs… option from the File dropdown menu. 

The HyperDocs window displays. 

4.​ Select Add in the top-right corner of the window.  

5.​ Browse to the location of the document to attach. Select the document, and then select OK. 

The options window displays. 

6.​ Select one of the options presented: 

●​ Embedded documents open in read-only state and can't be edited 
in ProFile 

●​ Linked documents open from the source and can be edited in 
ProFile. Any changes are saved in the source document in the file 
location 

7.​ Select OK. The document is attached to the field as a HyperDoc. 
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If you would like to see the field highlight with the document linked directly to the field, right-click on the field and select Attach to 
HyperDocs.  

✅The field displays in green color, indicating the HyperDoc attachment.  You can hover over the field to see the name of the document. 

 
Detaching HyperDocs from a field 

1.​ Right-click on the field with the attached HyperDoc. 

2.​ Select the Detach HyperDoc option from the menu. 

The document detaches and the field restores to its default color. 

⚠️Note: The document remains attached to the form but isn't linked to a 
specific field.  

 

Removing HyperDocs from a form 

1.​ Select the Hyperdocs… option from the File dropdown menu. 

The HyperDocs window displays. 

2.​ Select the document from the HyperDoc list of attached documents. 

The red X logo in the top-right corner activates. 

3.​ Select the red X logo. 

4.​ Select Yes to confirm the removal of the document.  

✅The document detaches from the form.​
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Using the Active Auditor in ProFile​
 
Profile’s Active Auditor displays messages that relate to the data file. These include messages that aren't checked, warnings, mistakes, fields 
that aren't checked, memos, fields that have review marks, and messages about EFILE. 
 
Error messages or errors that may restrict processing of the return display in red text. 
 
 
Accessing the Active Auditor 
 

The Active Auditor is accessed four ways: 

●​ Select the Active Auditor  icon  menu 
●​ Right-click on any form and select the option Show Auditor from the menu 

●​ Select Show Auditor from the Audit dropdown menu 

●​ Use F9 as a hotkey to open the auditor 

 
Selecting Active Auditor Options​
 
⚠️Note: Setting the Active Auditor options in one location applies to all open ProFile 
Modules (T1, T2, etc). 

1.​ Select Environment… from the Options dropdown menu. 

2.​ Select the Audit tab, the audit options window displays. 

Each section of the audit options window has pre-set default selections. 

⚠️Note: Modules may display different tabs in the Active Auditor based on the module 
itself, rather than settings. 

Preferences settings 

The Preferences section of the Audit tab includes settings that affect the display of 
warnings.  
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⚠️Note: ProFile recommends the Show Auditor Tabs option be selected to provide the clearest feedback and sign of errors on forms. 

 

Summary Tab Includes settings 

The Summary Tab Includes section of the Audit tab includes options that display in the auditor toolbar. Each of the selected options 
displays related errors in the corresponding Active Auditor tab. 

Prevent Filing settings 

The Prevent Filing section of the Audit tab includes options that halt the filing of the form. Errors created by the violation of these options 
must be cleared before filing can take place.​
​
Remove Audit Messages settings 

The Audit tab has settings about who can remove errors in the Active Auditor for a form.  

 

Clearing Active Auditor messages 

Error messages display as red text in the Active Auditor tabs. 

1.​ Double-click on an error warning in the tab. 

The error circles in red on the form. 

2.​ Resolve the error. The specific error in the tab details the issue. 

In some cases, the error – as identified by ProFile – may be acceptable to 
the Preparer ‌or the client. For example, an RRSP amount may be okay, but ProFile says the amount isn't within the range the CRA expects 
and says it's an error. 

In such cases, the individual selected in the Remove Audit Messages section of the Audit tab can sign-off, or approve the error.
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Setting up Data Monitors in ProFile 
 

ProFile’s Data Monitor feature displays any number of fields at the bottom of the Edit window. By default, the software monitors several key 
fields in the client file. Preparers can observe the totals for these fields change while working on different forms in ProFile.  

Selecting fields for data monitoring 

You may decide to monitor different fields. Then, as you change other parts of the file, look ‌on 
the screen to see how those changes affect the fields you are watching.  

A monitor amount that appears bold means that the last recalculation affected the field. A 
monitor amount that appears in red is a negative number.  

⚠️Hint: right-click on the Data Monitor, and then select Monitor from the menu to access 
several options, including the option to rename the monitor field description. This makes it easy 
to remember what's being observed. ​
 

To monitor a data field to the Data Monitor: 

1.​ Place your cursor in the field you’d like to monitor 

2.​ Select + to the right of the Data Monitor.  The field is added to the Data Monitor. 

3.​ To replace another field already on the Data Monitor, drag the field information with your cursor to that Data Monitor cell and 
release your mouse. The field code (or name, if there's one), along with the current value of the field, will appear in the monitor cell.  

 

 

​
​
​
​
Related Articles: 

Review our support article on adding more than four data monitors. 

Review our support article on copying data monitors to a new computer. 
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Managing ProFile Security Settings 

Data/File Locking in ProFile 

Data locking automatically locks a return to prevent any changes from 
occurring after the return’s status is set. 

Setting the data locking options: 

1.​ Open ProFile. 

2.​ Select the Module… option from the Options dropdown menu. 

The Module Options window displays. 

3.​ Select the appropriate module and year from the tab menu in the 
top of the window (for example, 2025 T1/TP1). 

4.​ Select the Data Locking tab. 

5.​ Select the appropriate option under the Client Status list. 

6.​ Select the appropriate option under the EFILE Status list. 

⚠️Note: One or more options may be selected from the list. 

7.​ Select OK.  

✅The file will lock when the selected criteria occur. ​
 

Setting the Print locking options: 

1.​ Select the Form Selection… option from the Options dropdown menu. 

The Form Selection window displays. 

2.​ Select the appropriate module and year from the tab menu in the top of the 
window (for example, 2025 T1/TP1). 

3.​ Select the dropdown menu arrow in the Status after printing section. The 
menu will expand.  
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4.​ Select the appropriate option from the menu. 

5.​ Set the appropriate options for each module. 

6.​ Select OK.  

✅After the return is printed, the return locks to the selected status. 
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PDF Locking in ProFile 
​
Data locking automatically locks a return to prevent any changes from occurring after the return’s status is set. 

Setting the PDF locking options: 

●​ Open ProFile. 

●​ Select the Environment… option from the Options dropdown menu  menu. 

The Environment Options window displays. 

●​ Select the PDF tab.  

●​ Select the appropriate option under the PDF Security option list: 

○​ None 
○​ Client Name + SIN/BIN/TAN/PN 
○​ Client Name + DOB/Fiscal EndDate 
○​ User Specified 

Setting Owner Password: 

The Set Owner Password option provides an additional level of security to prevent a 
locked PDF from being edited. 

1.​ Enter a password in the Set Owner Password field. Customers will require this password to open a file, in addition to any password 
set in the PDF Security option list. 

2.​ Select OK. The PDF locking selection applies. 
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Managing ProFile’s Password-Protection Function 
 

Frequently Asked Questions 

 
Which modules support access to password-protected files?​
Access by features to password-protected files applies to T1, T2, T3, and FX 
modules. 

Which tax years support access to password-protected files?​
Access by features to password-protected files applies to tax years 2015 and 
onwards. 

Which features currently support access to password-protected files?​
Currently the Hub and Corporate Linking features support access to 
password-protect files.  

 
Applying generic password protection to files​
 
Applying a generic password permits all future or updated files to be accessible by 
ProFile’s features. 

1.​ Open ProFile.  

2.​ Select Environment… from the Options dropdown menu. 

3.​ Browse to the Security tab.  

4.​ Select the Allow password protection for return(s) checkbox. 

5.​ Select the Create a generic password for return(s) checkbox. The Enter Password and Confirm Password fields activate.  

6.​ Enter a password and confirm it.  

⚠️ Note: Select the Show Password link to display the password as it's entered. Select the link again to hide the password.  

7.​ Select OK. The password-protection feature activates. Users can now apply password-protection to files.  
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Applying password-protection for files 
 

1.​ Complete a new file in ProFile.  

2.​ Select the Save As… option under the File 
dropdown menu. The Save As window displays.  

3.​ Select the Use generic password checkbox in the 
bottom-left corner of the window. The password 
stored in Environment Options… is applied. 

⚠️Note: Select the Show password link to display the 
password as it's entered. Select the link again to hide the 
password.  

4.​ Select Save. The file saves with the new generic 
password and is readable by the selected ProFile 
features. 

⚠️Note: Be sure you choose a password that you can 
remember. If it's lost, it can't be recovered, even by Intuit. 

 

Related Articles 

Review our support article for additional details. 
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Intuit “One Account” Login  
 

The Intuit “One Account” tool allows access to several Intuit products and services with a single log in and password. 

​
One Inuit products and services 

The One Account tool provides access to the following: 

●​ ProFile support community 
●​ QBOA 
●​ QBO 
●​ TurboTax Online 

​
One Account access: 

Customers can create a One Account when accessing a supported service for the first 
time. 

The One Account login window displays when accessing a supported service. 

Select the New to Intuit? Create an account link to create a new account. 

 

⚠️Note: The same email should be used to purchase and login to any Intuit 
product. If you need to change the email or any account information associated with 
your One Intuit account, please review this support article. 
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Using Backup to Cloud Feature in ProFile 
 
Backup to Cloud is a new ProFile feature replacing the existing ProFile Review function. 

ProFile users can safely backup as many files and returns as they want on the virtual cloud. They can retrieve the files at any time. 

What's the Cloud? 
The Cloud is ProFile’s online repository that provides unlimited file storage and is available for backup and retrieval 24-hours per day. 
 
What type of files can I back up? 
Users can backup files for any module (T1, T2, T3, or FX) to the Cloud. Other modules, such as T3 and FX, can only undergo backup via 
the Save As… option in ProFile. 
 
What years are supported? 
Backup to the Cloud only supports the current year module, not previous years. However, if you have used the backup in previous year, 
those backups would continue to exist. 
 
Is there any limit to the number of files I can back up at one time? 
Users can back up 80 files at one time to the Cloud. 
 
Do I need to make a new Intuit account to use the backup to Cloud feature? 
No, users can use the same Intuit account used for ProFile Review. 
 
I backed up a file to the Cloud…is the original file on my hard drive deleted? 
No, the original file is still stored on your hard drive where it was. 
 
I deleted a file in the Cloud…is it gone forever? 
The file only deletes from the Cloud. It doesn't delete from the local storage directory. 
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Setting Options for Backup to Cloud 
 
The Backup to Cloud wizard displays upon starting ProFile. 

1.​ Select the Environment Options link to set options for backup, the Environment 
Options window displays. 

2.​ Browse to the Backup to Cloud tab. 

3.​ Select the Enable backup to Cloud for this computer option. 

4.​ Select the Automatically back up returns on saving option to enable the 
auto-backup option. This isn't mandatory, but it helps make sure that any time the 
file is saved on the desktop that it's also backed up to the Cloud. 

 

Backing up a file to the Cloud: 

1.​ Open the file to upload in ProFile. 

2.​ Select the Save As… option from the File dropdown menu. 

The Save As window displays. 

3.​ If you selected the automatic backup option during setup, you now see a 
backup option when saving the file. 

Note that the Enable backup for this file option is already selected, and the status 
will show  Ready to backup. 

4.​ Select Save. 

A confirmation message indicates the backup has been successful. 

If you didn't select the automatic backup option during setup, you will see an option 
when saving the file in the future to back up to the Cloud or save only to the 
desktop. 

5.​ Users can either select the Enable backup for this file option or leave it 
unselected.  
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6.​ Select Save. The file is saved either to the desktop only or to both the desktop and the Cloud. 

✅A confirmation message indicates the backup was successful.​
 

Related Articles 

Review our support article for more information on backing up multiple files, reviewing files, and downloading or deleting files from the 
Cloud. 
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What Can Undergo EFILE in ProFile 
 

The CRA makes changes each tax year as to what can (and can't) undergo the EFILE process.  

ProFile maintains a support article that addresses the EFILE status of all modules, as well as independent forms that undergo EFILE 
separately from the return (for example, T1135, etc.). 

Review this support article for a full list of forms and years that you can EFILE from ProFile.  
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Viewing EFILE Reports in ProFile 
​
EFILE reports provide Preparers with the date, time, and the confirmation number of the EFILE from CRA. 

⚠️Note: EFILE reports are no longer available for returns after 2023. You are able to access previous reports for 2023 and previous 
returns.​
 

To view reports from files used during current EFILE and NetFile services: 

1.​ Select the Reports option from the EFILE dropdown menu , and then select the Current 
option. 

The Open EFILE Report window displays. 

2.​ Select the type of file in the Files of type field from which you want to generate a report: 

●​ EFILE Submission files (*.TAX)  
●​ TP1 NetFile Submission files (*.EAX) 
●​ Session logs (*.SLG)  

3.​ Session logs are descriptions of events that occurred while you were connected to the 
NetFile Québec website. If you choose Session logs, select a session log and select Open 
to view the full report. 

4.​ For other file types, select the option and select Open. ProFile displays the report information. 

5.​ Select Print from the report to print a copy for your records. 

 

Setting up a shared EFILE folder​
 
If you installed ProFile onto a shared network folder, you can use the default folders created during installation. For each module that uses 
EFILE, you will find appropriate EFILE folders within each module's files folder.  

Alternatively, you can use any shared folder on your network as a shared EFILE folder. To do so, you must specify that folder on each 
workstation. 
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For T1/TP1 returns 

1.​ Select EFILE, and then Options….  

2.​ Select the option for the EFILE service that you want to configure from the left-side menu. 

3.​ Select the Common option under the T1 section of the General menu. 

4.​ Select Browse. The EFILE Directory window displays. 

5.​ Browse to the folder used as a shared EFILE folder. 

6.​ Select OK. 

7.​ Select OK in the EFILE options window. The folder is assigned. 

​
For T2 returns 

1.​ Select the T2 EFILE option under the T2 section of the General menu. 

2.​ Select Browse. The EFILE Directory window displays. 

3.​ Browse to the folder used as a shared EFILE folder. 

4.​ Select OK. 

5.​ Select OK in the EFILE options window. The folder is assigned.  
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Using Flexible Licensing in ProFile 
​
Flexible licensing suspends a ProFile license temporarily on one computer so the license may be activated on another computer... without 
having to delete the license or purchase an additional seat. 

For example, you can suspend your Profile license on an office computer and activate the same Profile license on a laptop to meet with 
clients in the field. When you return to the office, simply suspend the license on the laptop and resume the license on your office computer. 

What’s a Seat? 

The number of seats determines the maximum number of users that can be activated on the License Key combination. When you purchase 
a base license, you get one seat. When you purchase additional licenses, you get an increase to the number of seats that can be activated 
on your license. 

What’s required to use Flexible Licensing? 

Flexible licensing requires:​
​
•    Tax year 2016 or later license (earlier tax years aren't supported at this time)​
•    ProFile version 2016.0.3 or later​
•    Internet connection during activation and suspension of license 

Can I still work offline? 

Yes. Once you have activated your license you can use ProFile without an Internet connection. Features like Auto-fill my return and EFILE 
will still require an Internet connection to work.​
​
What does flexible licensing cost? ‌ 

There’s no cost for flexible licensing. The feature is included as part of your license purchase. 

How many machines can I install ProFile on? 

Unlimited. ProFile is a free download, but the licensing determines what can be done with the program. You can add your licenses to as 
many computers as you want with flexible licensing. You can only have the number of licenses you paid for active at the same time.​
​
Is Flexible Licensing going to be on by default? 

No. The flexible licensing option is activated manually. 
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Flexible Licensing: Enable during Activation​
 
Flexible Licensing can be enabled during the ProFile activation sequence, for Preparers who want to start using the feature right away. 
 

Enabling Flexible License during Activation: 

1.​ Enter your product code and license key during activation. 

2.​ Select Next - Setup Flexible Licensing.  

The Flexible Licensing Settings window displays. 

3.​ Select the Enable flexible licensing on this computer 
check box. Select either Manual or the Automatic mode to 
activate your choice. 

4.​ The Manual mode displays the choice of two additional 
options: 

○​ Prompt me every time when I close ProFile – 
selecting this option results in ProFile prompting the 
user to suspend your license when closing the 
application​
 

○​ Don’t prompt me. I’ll do it manually – selecting 
this option requires the user to suspend their license 
manually themselves when closing the application 

5.​ Select Save to save your preferences.    
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Flexible Licensing: Suspending the License Automatically 
 
The Automatic mode automatically suspends or activates your licenses when you close and open ProFile, respectively.  

⚠️Note: A working internet connection is required to suspend a license.​
 

Suspending the License Automatically: 

1.​ Select the Configure Flexible Licensing option from the Help dropdown menu. 

The Flexible Licensing Settings window displays. 

2.​ Select the Enable flexible licensing on this computer ​
box. 

3.​ Select Automatic mode. 

4.​ Select Save to save your preferences.   

5.​ Close the ProFile application. You can do this by selecting the X icon on the 
application, or by choosing Exit. 

The ProFile application closes. 

6.​ A message indicating that your license is suspended on the computer 
displays. 
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Flexible Licensing: Suspending the License Manually 
​
Manual suspension occurs when the user suspends the licensing themselves in 
ProFile. 

⚠️Note: This process needs to be undertaken each time ProFile is closed to 
ensure the Flexible Licensing is properly suspended. Proper suspension 
ensures the license can be activated on another computer. 

 

Suspending the License Manually 

1.​ Save any files being used in ProFile. 

2.​ Select the X icon in the top-right corner of ProFile or select the Exit 
option under the File dropdown menu. 

A prompt displays asking if you would like to suspend your license and work on 
another computer. 

3.​ Select the Yes option. 

A message displays, double-checking the license suspension can continue. 

A confirmation message displays when the license is suspended. 
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Managing T1 Returns in 
ProFile 
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Overview of T1 Module in ProFile 
​
What’s a T1? 

The T1 General Tax Form (usually referred to as a “T1”) is used by individual Canadians to complete their personal income tax return.  

It has five sections for personal and income information: 

●​ Identification: For details including name, address, Social Insurance Number (SIN), and marital status 
●​ Total income: For declaration of income, including employment, self-employment, disability, foreign income, and any others 
●​ Net income: Where childcare expenses, union dues, and more are subtracted from total income 
●​ Taxable income: Where allowable deductions like capital gains are subtracted from net income 
●​ Refund or balance owing: Where it's determined if any money must be paid, or any money is paid back 

​
Submission Dates for T1: 

April 30 of the following year is the deadline for most individuals to file a T1 return, or June 15 of the following year for self-employed 
individuals and their spouses or common-law partners.  

If April 30 falls on a weekend, the following Monday becomes the deadline. 

If the individual owes money to the CRA, the due date of April 30 is the hard due date for filing. 

Late payment results in penalties being applied by the CRA.  
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Authorizing or Canceling a Representative for T1 
 

As of July 2025, Preparers will no longer be able to authorize or cancel a representative in EFILE software like ProFile. Preparers will need to 
receive permission via a client’s CRA account. The form can still be printed or signed electronically through Intuit Sign. However, it can't be 
emailed through the software. 

For more information, read the CRA’s documentation regarding this process.  
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EFILE form MR-69 in ProFile for T1 
 

The MR-69 form is the Authorization to Communicate Information or Power of Attorney form in ProFile. 

ProFile users can upload a signed copy of the MR-69 for RQ to retain in their records using ProFile version 2019.3.0 or later. 

Review our support article on the process for T1 and T2. 
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Completing the T183 Form 
 

1.​ Select the Form Explorer option from the 
GoTo dropdown menu. 

2.​ Search for T183 and open the T183 form 
from the results.  

⚠️Note: most of the content for the T183 form 
sources from the Preparer information entered 
under the Options > Environment… menu. 

3.​ Complete the T183 form. 

Is it necessary to retain the T183 form? 

A signed copy of Form T183 must be kept by the 
taxpayer in case the CRA asks for it. 

⚠️Tip: Use the Search bar to quickly find and 
add forms and schedules to your returns without using the top toolbar menu to increase efficiency. 
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Using T1135 EFILE for T1 in ProFile 
​
All Canadian resident taxpayers (including nonresident trusts deemed resident in Canada by section 94 of the Act) are required to file Form 
T1135, Foreign Income Verification Statement, if at any time in the year the total cost amount of all specified foreign property to the taxpayer 
was more than $100,000 (CAD). 

⚠️Note: The T1135 doesn't EFILE with a T1 or T2. It must undergo EFILE independently. 

​
Finding the T1135: 

Enter T1135 into the forms search bar menu. Select T1135 Foreign income 
verification statement from the search results. 

The initial question is in the Filing section of the T1 Info tab. 

​
EFILE the T1135: 

1.​ Ensure the related Yes/No question is answered affirmatively on the T1 Info tab. 

2.​ Select the EFILE the T1135… option from the 
EFILE dropdown menu. A transmission 
window will display indicating that the T1135 
is ready to transmit.  

3.​ Select OK. The T1135 transmits to CRA, and a 
confirmation number is provided.  

⚠️Note: The confirmation number can also be viewed on the information tab of a T1 or T2 return, post-transmission.​
​
Related Articles 

Common questions regarding T1135 are found on the CRA website.  
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Using CRA Data Import with AFR for T1 in ProFile 
​
Auto-Fill My Return (AFR) is a secure CRA service. It allows authorized representatives to electronically request and receive certain tax 
information to fill in parts of their client’s income tax and benefit return. ProFile offers the service for both single and multiple individual T1 
returns. 

Acquiring AFR permissions 

The tax Preparer must have a valid authorization from the taxpayer to access the 
Represent a Client website. There are two ways to acquire this authorization: 

●​ The taxpayer can access CRA's My Account service. Preparers request that the 
taxpayer enter the Rep ID to authorize the Preparer as an individual, a Group ID 
to authorize a group of representatives, or a business' Business Number (BN) to 
authorize all employees of a business 

●​ Request the permission of the taxpayer via a T1 Authorize a representative 
submission as noted in the Authorizing or Cancelling a Representative section of 
this guide. 

 
⚠️Note: To learn how to obtain Represent a Client access, review this CRA article. 
​
Importing data with AFR​
 

1.​ Open or create a T1 return. 

2.​ Select the Import CRA data option from the File dropdown menu. The CRA 
Data Import Tool window displays. 

3.​ Select Launch CRA Website. The CRA's Represent a Client window 
launches in a separate browser window. 

4.​ Sign in to the CRA site with your Represent a Client credentials. The CRA 
Data Import window lists the clients whose SINs can be entered into the 
CRA website. 

5.​ Select the client and select Next to provide confirmation. The CRA system 
processes the request. The Successfully Connected message displays when 
the connection has been made between the ProFile and CRA systems.  
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6.​ ProFile’s Data Import Worksheet window displays. The default display setting is the basic view. Select the + icon next to each 

statement to reveal the expanded view, which displays more details. 

7.​ Review the data and forms to be imported. If correct, select Import Selected Data. Select Close. 

8.​ To review the data imported, select the Data Import tab in ProFile's Auditor. 

⚠️Tip: If you have used AFR before and are using it again, make sure you uncheck items that have already been imported. This can cause 
duplicate imports that can add too much information.  This reduces the need to delete duplicate slips. 
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Attaching Documents for EFILE of TP1 Returns with the Attach a Doc Feature 
​
When are attachments transmitted? 

Revenu Quebec (RQ) allows the transmission of supporting documentation via ProFile’s Attach a Doc feature after an amended return has 
been sent but before a notice of assessment (NOA) has been returned by RQ. 

What file types are supported? 

The following file types can be transmitted as attachments: 

●​ .pdf 
●​ .jpg 
●​ .jpeg 
●​ .tiff 
●​ .tif 

What's the maximum attachment size? 

The maximum attachment size is 20 megabytes (MB). This is an RQ limitation.​
 

Is there a limit to the number of attachments transmitted? 

Submissions are limited to 25 attachments each. This is an RQ limitation. 

 

Review our support article on using the Attach a Doc feature for TP1. 
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Using Couple’s Returns for T1 in ProFile 
 

Creating a couple’s return 

1.​ Open or create the T1 return for the client.  

2.​ On the Info form, select either Married or Living common-law for the 
marital status.    

3.​ Select Switch to spouse . The Couple Returns window displays. 

4.​ Choose whether to create a new return for the spouse or couple the file to an 
existing return.  

●​ Select Create a new return for spouse to open a new return for the spouse, or, 

●​ Select Open an existing return to browse to a file on your hard drive and select it 

⚠️Note: After combining the data, ProFile will ask if you want to delete the original file for the spouse. Remove the file to avoid having 
the same return in both files. This can cause problems.  

5.​ Select the Save option from the File dropdown menu. 

ProFile saves both spouses' tax returns in the same data file. This keeps the tax returns together as file operations are performed on the tax 
return file (for example, backing up to a disk).  

6.​ Once returns are coupled, select <F5> on the keyboard to toggle between the returns. 

 

Uncoupling a couple’s return 

1.​ Open the coupled return.  

2.​ Select the Uncouple option from the File dropdown menu  menu. 

3.​ Confirm the desire to uncouple the returns. ProFile automatically prompts the option to save the spouse's return in a separate file.  
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4.​ Select Save. The client's file keeps the coupled file name (for example, Couple, Joe and Thelma.T25). It may be renamed by 

selecting the Save As option from the File dropdown menu. 

5.​ On the Info form in each file, select Widowed, Divorced, Separated, or Single for the marital status. 
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Family Linking for T1 Returns 
 

File management features make it easy to work with linked T1 or T1/TP1 files for members of the same family: 

●​ Linking family returns 
●​ Working with linked files 
●​ Printing linked files 
●​ Saving linked files 
●​ Sharing income between spouses 
●​ Sharing data between family members 
●​ Estimating Child Tax Benefits 
●​ Open and close family files 

Working with linked family files 

Once linked, family files can be opened and closed together. 

If you prefer working with family files open together, open them all together when beginning to work on a set of family files.  If files were 
closed together, (for example, File -> Close family) ProFile will open the returns together. 

If you close the file for one family member at a time, all family files will open together when you open all files at once. This won't happen 
until the next time you open all files at once. 

Switch between Family Members 

Use the toolbar icon, the Form menu, or the Window menu to switch between open files for members of a family. 

Print Family Files 

When selecting the File -> Print option for a linked file, the Print Selection dialogue box displays a tab for each family member whose file 
is currently open to allow printing returns for the whole family at once. 

File Properties 

View the File Properties details for all family files open together and listed in the Window menu. 

Deactivate Family Files 

To deactivate the family file-handling features, clear the checkbox Allow family linking under Options -> Module > T1/TP1 -> General -> 
Calculation options.​
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Adding Dependants for T1 in ProFile​
 
There's no limit to the number of dependants that can be added to the form. A new blank column displays when the last column provided 
is populated. 

 
Completing the “Dependant information” form: 

1.​ Enter the term dependant into the ProFile search field . Select the form from the 
search results (for example, Dependant information). 

2.​ Enter the dependant information in full.  If there is more than one dependant, 
complete information in each column. 

Personal information entered on the Dependant form automatically populates for both 
spouses, regardless of which is chosen. 

Selecting family linking: 

1.​ Select the Module… option from the Options dropdown menu. 

2.​ Ensure the Allow family linking option is checked in the Allow family linking 
section of the General tab. 

3.​ Select OK. 

4.​ Identify the dependent in the Dependant 
information form that to link. 

5.​ Right-click in one of the dependent’s form fields. 
Select the Return for option from the menu. 

6.​ Select Yes when asked Create a new return for? 

✅The new return is created for the dependant. 
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Using a Medical Expense form for T1 in ProFile​
 
Taxpayers may claim medical expenses for any 12-month period that ends in the current tax year. Expenses already claimed on last year's 
tax return can't be claimed again. Generally, all amounts paid can be claimed even if they weren't paid in Canada. 

Opening the Medical Expense form: 

1.​ Search using the term medical in the ProFile search bar,.  

2.​ Select the Medical expenses form displayed in the search results. 

 

Optimizing Medical Expenses for Coupled Returns 

The Medical Expense form in ProFile automatically shares information between coupled returns. 

1.​ To optimize medical expenses, select the Yes option 
to the Optimize medical expenses? question at the 
top of the form.  

ProFile determines which taxpayer should claim the 
deduction at line 33099, according to the lowest net income 
(if the taxpayer can claim all expenses). 

2.​ To decide independently which spouse should claim 
the deduction, select the No option to the Optimize medical expenses? question at the top of the form and select the Yes option 
to the Are you claiming medical expenses? question.  

3.​ Select Percentage and enter it in the corresponding field for the current return to allocate a percentage to each spouse. The 
spouse's return will automatically reflect the remaining percentage. 
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Using a Charitable Donations Form for T1 in ProFile​
 
The ProFile Donations form is used to enter charitable donations for the taxpayer. Donations can be entered for both Canadian and U.S. 
organizations. 

Search for the term donations in the ProFile search bar  menu. Select the appropriate form (for example, Charitable donations). 

 
Carrying forward donations​
 
If a return is carried forward from a previous taxation year, ProFile copies the list of organizations into the Charitable donations details and 
Donations to U.S. organizations tables, but leaves amounts as 0.  

Any donation amounts can be entered to the same organizations for the current year in the appropriate rows.  

1.​ When completed, delete the remaining organizations, right-click in each table and select the Remove 'zero' lines option. 

2.​ If the taxpayer has donation amounts from slips (for example,T4 slips), enter those amounts on the related slip or slips (for example, 
T4, T3, T2202A, T4A, and T5013). ProFile automatically carries donation amounts from slips to the Reported on slips line in the 
Donations worksheet. 

The donation carries forward and displays at the bottom of the Charitable donations form. ProFile automatically claims older donations 
first to ensure that the taxpayer uses them before they expire. Charitable donations for up to 5 years are eligible for carry forward. 

⚠️Tip: If you have multiple tax receipts from the same charity, use Tapes to add them up quickly and ensure accuracy.  

 

Transferring donations to a spouse​
 

1.​ Open the donations form. 

2.​ Right-click on the form and select the option Transfer 
all donations or Transfer current donation. 

✅The donations transfer to the spouse.  
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Using S3 Principal Residence Form in ProFile​
 
Starting with the 2017-tax year, Preparers must complete forms T2091 ‌or T1255 for each real estate property disposed of by taxpayers in 
the year, including their principal residence.  

In case of multiple properties disposed of by the taxpayer in the year, complete forms T2091 and/or T1255 for each property.  

​
How are the updated and new forms managed?  

The Preparer completes the Schedule 3 form and S3 Principal Residence Details Form.  

The Preparer completes the new T2091 and/or T1255 form and sends a copy to the client for their signature. Clients sign the new form and 
return it to the Preparer.  

The T1255 and T2091 forms each contain some data that transmits to CRA.  

Complete the TP274 form if the client is a resident of Quebec.  

 

Can a Preparer enter data directly into the new T1255 or T2091 forms?  

The new T1255 and T2091 forms have sections for property descriptions. This information comes from the information you enter on the S3 
Principal Residence Details form. Enter any remaining required data on the new forms manually.  

 

Is it necessary to retain the T1255 or T2091 forms?  

A signed copy of Form T2091 - Designation of a Property as a Principal Residence by an Individual (or Form T1255 for deceased taxpayers) 
must be kept by the taxpayer in the case the CRA asks for it. 

 

Undertaking the Workflow​
 

1.​ Complete the individual T1 Info pages for the residence owner and spouse (if applicable).  

2.​ Open the Schedule 3 form. 

3.​ Select an option under Line 179.  
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⚠️Note: The following steps should be undertaken only for one spouse's 
return if the property is owned 50/50 between spouses.  

4.​ Select the S3PrincipalResidenceDetail link located above the section.  

The S3 Principal Residence Detail form opens.  

⚠️Note: Each property that is disposed of automatically links to a T2091 form. 
Each property disposed of by the designated legal representative of a deceased 
taxpayer automatically links to a T1255 form.  

5.​ Complete the S3 Principal Residence Detail form as required. Note that 
the section Designated by legal representative of deceased? is 
automatically populated by the names of the residence owner and spouse 
(if applicable).  

If the Designated by legal representative of deceased? option isn't selected, 
the Description of property section of the T2091 form will  populate.  

If the Designated by legal representative of deceased? option is selected, the 
Description of property section of the T1255 form populates. 

If the spouse owns the house, the spouse who doesn't own it doesn't have to fill 
out a T2091 or T1255 form.  

If the residence was owned in a 50/50 split, a T2091 or T1255 form must be 
completed for each spouse as follows: 

●​ If option 1 in Line 179 of Schedule 3 was selected, complete only the first 
page elements of the T2091 form that were not automatically calculated. If 
options 2 or 3 in Line 179 of Schedule 3 were selected, it's necessary to 
complete the remaining elements of the form applicable to the specific situation, or:​
 
 

Related Articles 

Review our support article for additional details. 

 
119 

 

https://profile.intuit.ca/support/en-ca/help-article/spouse-partner/complete-s3-principal-residence-form/L49xUFZxC_CA_en_CA?uid=mj03lyhy?src=ProFileUserGuide


 

Using Pension Split Optimization for T1 in ProFile​
 
Canadian residents who received eligible pension income during the taxation year may be able to allocate up to half of their eligible 
income to their spouse (or common-law partner) for income tax purposes. 

Completing T1032 form: 

1.​ Open form T032, Joint Election to Split Pension Income. 

2.​ Indicate at the top of form T1032 whether you are the Pensioner 
(transferring pension income to his/her spouse) or the Pension 
Transferee (receiving pension income from his/her spouse). 

3.​ Enter the amount of the elected split pension on Line 22 of the 
form. Based on your Pensioner/Pension Transferee selection, the 
amounts will automatically flow to lines 21000/11600 of each of the 
spouse's returns. 

​
Utilizing the pension optimizer worksheet: 

1.​ Open the form T1032OPT, Optimize – Split-pension income. 

2.​ To view the amount that ProFile recommends that the taxpayer 
transfer to his/her spouse or common law partner, right-click on the 
worksheet and select the Optimize split-pension income option. 

​
Utilizing scenarios in the Calculator section: 

1.​ Open the form T1032OPT, Optimize – Split-pension income. 

2.​ Enter the amount of pension income to be split in the Elected split-pension amount box under Scenario # 1. 

3.​ Press Enter. The calculator displays the Total Payable and Balance Owing for everyone, as well as combined totals for the couple. 

 

Related Articles 

Review our pension-splitting support article to learn more. 
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Handling Self-Employed Forms 
 
Using Business Statements for T1 in ProFile 
​
There are multiple business statements in ProFile, including: 

●​ T2125 - Statement of Business or Professional Activities 
●​ T776 - Statement of Real Estate Rentals 
●​ T2042 - Statement of Farming Activities 
●​ T2121 - Statement of Fishing Activities 
●​ T1163 and T1273 - AgriStability 

Each statement has their own set of forms, such as the asset, CCA, and summary forms. 

Amounts from certain slips are transferable to a business statement. It gives the option to transfer on 
the slip.​  

These statements are multi-copy forms. To create a secondary statement, select the New Form option 
from the Form dropdown menu. 

⚠️Note: If you need multiple Business Statements or forms, help ensure you are on the form and 
select Form > New Form.  

The new form will be represented with the #X beside the form name in your tabs based on the number 
of forms you create.​ ​  

Deleting business statement sets (T4slip) 

If you delete any form in a business statement set, ProFile deletes all the related forms in the same set. 
ProFile automatically selects to print any of the business statement forms that are used. Unused forms in a set have no impact on a tax return 
filing. 

To clear a particular form in the set, open the form in the Edit window and select the Clear Form option from the Form dropdown menu.  

This option doesn't impact other forms in the same set. 

Review the business statement and Asset details entries in ProFile’s Help feature for additional information. ​
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Adding Motor Vehicles for T1 in ProFile 

The Motor vehicle expenses (Business) worksheet lists motor vehicle expenses used for business purposes, related to the T2125, T2121, 
T2042 and Quebec business statements. 

From the Allocation of expenses dropdown menu, select your business statement (if you have not yet opened a business statement, the 
drop down list will be empty).  

Data entered on the Business Auto form flows to the selected business statement(s). 

In the case of the T2125, T2121, and T2042 business statements, ProFile transfers automobile expenses to different areas on the statements 
depending on the taxpayer's percentage of ownership of the business: 

●​ If the business is a sole proprietorship (% ownership = 100%), then the automobile expenses are transferred to the expense section 
of the business statement (line 9281 or 9819, depending on the business statement). 

●​ If the business is a partnership, the expenses are transferred to line 9943, Other amounts deductible from your share of net 
partnership income (loss). 

As you complete the Business Auto worksheet, ProFile automatically transfers the required information to the related Quebec business auto 
form (for example, TP80Auto, TP1FishingAuto). 

 
Capital Cost Allowance (CCA) 

Chart C of the Business Auto worksheet lets you calculate the Capital Cost Allowance (CCA). CCA amounts are transferred to the business 
statement's CCASummary or the CCA (assets owned by partner) table of the relevant business statement, depending on whether the 
vehicle is owned by the business. This is specified in the Owned by business? column of the Allocation of expenses table. For vehicles 
owned by a partner in a business, ensure that the Owned by business? column is set to No for the related business statement. 
 
Sharing automobile expenses between spouses 

ProFile doesn't automatically share the details of motor vehicle expenses with the spouse's return. If both spouses have expenses related to 
the business use of an automobile, they will each have to create their own Business Auto form. 
 
Related Articles 

Review our support article to learn more about CCA for motor vehicles. 
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Using a Motor Vehicle Expenses Form for T1 in ProFile  
​
Form T777 calculates allowable employment expenses.   

⚠️Note: This applies to T7777 vehicles only.​
​
Enter the term T777 into the ProFile search bar  menu and select the appropriate result. 

There are four forms related to employment expenses:  

●​ T777: Enter employment expenses. 
●​ T777Details: Enter employment expenses for commission, and non-commission employees. 
●​ T777Other: Enter expenses for musicians, forestry workers, and apprentice mechanics. 
●​ T777Auto: Calculate automobile expenses related to earning employment income. 

​
T777Auto#: Motor vehicle expenses: 

This form calculates automobile expenses related to earning employment income. 

1.​ Create a new T777Auto worksheet for each automobile. 

Complete the expense details for the automobile. Any number of copies of the form may be created. Right-click on the form and select the 
New Form option from the menu.  
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Adding Assets and CCA for T1 in ProFile 
​
Asset details forms are part of the business-statement set. For each business statement, ProFile creates a corresponding asset details and 
asset list form. For example, when creating a T2125#1 form, ProFile creates the corresponding forms T2125Asset#1 and T2125AssetList#1. 

Use asset details and asset list forms to track business and rental assets. Enter asset information on the asset details form. ProFile 
automatically transfers this information to the corresponding asset list form. The asset list form displays all assets in a single table that you 
can print.  

⚠️Note: It isn’t possible to print the asset list form. 

Entering asset information: 

1.​ Complete a separate entry for each asset.  

2.​ A list of assets appears in the panel on the left of the asset details form. Select one of these items to display the asset details for a 
particular asset.  

3.​ Select New to enter information in a blank column. ProFile automatically numbers each asset as entered on the information and 
creates a blank entry for the next asset. Complete a separate entry for each asset.  

4.​ Enter details for each asset under the Federal/Quebec headings. ProFile automatically calculates the net cost or proceeds and 
transfers the amount to the CCA form to calculate the capital cost allowance (CCA), recapture, or terminal loss.  

Capital Cost Allowance (CCA) form 

Capital Cost Allowance (CCA) forms and summaries are part of the business statement set. For each business statement, ProFile creates a 
corresponding CCA and CCASummary form. For example, when creating a T2125#1, ProFile creates the corresponding forms 
T2125CCA#1 and T2125CCASummary#1. 
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Using the Employment Expenses form for T1 in ProFile 
​
Use form T777 to calculate allowable employment expenses.  

There are four forms related to employment expenses:  

●​ T777 
●​ T777Details 
●​ T777Other 
●​ T777Auto 

Enter employment expenses for commission, and non-commission employees on T777Details.​
​
Enter expenses for musicians, forestry workers, and apprentice mechanics on T777Other.  

Use form T777Auto to calculate automobile expenses related to earning employment income. 

​
T777Auto#: Motor vehicle expenses: 

Use this form to calculate automobile expenses related to earning employment income. 

1.​ Create a new T777Auto worksheet for each automobile. 

2.​ Complete the expense details for the automobile.  

3.​ Right-click on the form and select New form from the context-sensitive menu. 
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Using Comparative Summary for T1 in ProFile 

ProFile provides summary forms that present the tax return data in different ways. These include: 

●​ Summary - Tax Summary (Federal): This form displays all the non-zero line items of a single taxpayer's T1 return (each field that 
contains data in the return).​
 

●​ T1Summary - Tax Return Summary, TP1Summary - Tax Summary (Québec): These forms display major items from the taxpayer's 
return​
 

●​ 5Year - 5 Year Tax Summary (Federal), TP15Year - TP1 5 Year Tax summary (Québec): This form displays the major items for a 
single taxpayer's last five years of tax returns.​
 

●​ Comparative - Comparative Tax Summary (Federal), TP1Comparative - TP1 Comparative tax summary: This form compares 
the major items from this year's tax return to last year's tax return for a single taxpayer. If the return is carried forward using Profile, 
last year's amounts appear automatically on the comparative summary.​
 

●​ NRTC - Comparative NRTC Summary: This form compares the non-refundable tax credits on the federal and provincial tax returns 
 

●​ T1Review - T1 Review, TP1Review (Québec): Like the Comparative Tax Summary, this form compares the major items from this 
year's tax return to last year's tax return for a single taxpayer, with a special focus on review. The form uses the variance thresholds 
specified under Options -> Module… -> T1/TP1 Review to highlight significant changes between current and prior year returns. 
it's also possible to adjust the variance threshold in the Review preferences section of the form. ProFile calculates the differences and 
displays them on the T1/TP1 Review tab in dollar and/or percentage amounts.  

●​ Five-year comparative summaries are part of the business-statement set. For each business statement, ProFile creates a 
corresponding five-year comparative summary form. For example, if creating a T2125#1 form, ProFile creates the 
T2125Comparative#1 form. This form is used to compare up to five years of business statement information. 

 

ProFile automatically carries forward previous-year business statement information from the previous year to this form. Enter any additional 
information directly in the summary. 

If creating a new return, rather than undertaking the carry forward of an existing return, enter the previous year information directly on the 
comparative summary. ProFile carries forward this information in the following year.  
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Using Tax Planner for T1 in ProFile 
 

The tax planner in ProFile prepares a projection of the taxpayer's position for the next taxation year. 

Tax Planner is an unlimited form, so as many different scenarios as required can be created for a single T1 file.  

​
Creating a T1 tax plan 

1.​ Enter the term tax plan in the ProFile search bar . 

2.​ Select the PLAN: Tax planner option from the search results. The tax planner displays. 

3.​ Right-click on a form field and select the New form option from the menu. 

4.​ Enter a description for the situation in the Description field. This description displays in the Form Explorer to distinguish between 
the different scenarios created. 

⚠️Note: When creating a new plan, ProFile creates new T1 plans for the client and spouse, all in the same numbered set. 

​
Transferring data from the current year’s tax return 

To save time when you start a new plan, copy the amounts from the current year's tax return to get started. 

1.​ Open a completed T1 client file. 

2.​ Open the tax planner from the Client category of the Form Explorer. 

3.​ Right-click on a form field and select the Copy T1 return option from the menu. The return’s data imports into the tax planner. 

4.​ Change any amounts to reflect the client's new projections for the year. 
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Filing a T1 for a Deceased Taxpayer in ProFile ​
 
Complete a return for a deceased taxpayer who's single: 

1.​ Create a new T1 return in ProFile. 

2.​ Browse to the Info sheet. 

3.​ Enter the date of the client’s death in the Date of Death 
field under the Taxpayer personal information section. 

The date of the client’s death in the Is this return for a deceased 
person? section of the T1 sheet updates automatically. 

⚠️Note: If the deceased taxpayer is married, the status 
of the individual’s spouse changes automatically to 
Widowed on the spouse’s form. 

 
Carrying forward a coupled deceased return​
 
When carrying forward a coupled file in which a spouse 
files a deceased return for the previous taxation year, 
ProFile automatically carries forward only the return for the surviving taxpayer. 

 
Completing Special return for deceased taxpayer 
 

1.​ Enter the date of the client’s death in the Date of Death field under the Taxpayer personal information section. 

2.​ Scroll down the Info sheet to the Special return for the deceased taxpayer (Other than “final return”) section. 

3.​ Review the options in the section and select one if applicable. 
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Completing a T1 Adjustment 
​
ProFile can automatically calculate the T1-ADJ form, if an adjustment is required. 

⚠️Note: ProFile recommends using the ReFILE feature where possible: It's a faster, and 
easier-to-use experience when compared to undertaking a T1 adjustment. Use T1 adjustment where 
ReFILE isn't an option. Also, note that a T1ADJ form can't be electronically filed. 

Using form T1ADJ: 

1.​ Open a T1 file you made and filed before. To save the original tax return, choose Save As from 
the File dropdown menu and save the return with a changed name. 

2.​ Select the option Snapshot/variance from the Audit dropdown menu. The 
Snapshot/variance window displays. 

3.​ Select New, A new entry displays in the Active list. 

4.​ Name the snapshot something that identifies why the return is being adjusted (for example, Additional T3 slip), and then select 
OK. This records amounts in key fields that ProFile will check for variance after the return adjusts. 

5.​ Browse to the form or slip that requires adjustment and key in the new values. 

6.​ Use the Form Explorer (or press <F4>  or use the Search bar) to open a copy of the T1ADJ. ProFile allows unlimited copies of this 
form to be made, so additional adjustments to the return can be filed as necessary. 

7.​ Right-click on the form and select the New option from the menu to create another copy. 

8.​ Right-click on the T1-ADJ form and select the Adjust from [snapshot name] option with the name of the snapshot. 

9.​ ProFile compares the original return to the revised data. The software automatically detects the impact on all relevant fields, and 
completes the table with line numbers, names and changed amounts. This only applies to fields with CRA line numbers. 

10.​There's a free-form area on the T1-ADJ where Other details or explanations are provided. To create separate paragraphs in this 
section, use <Shift + Enter> to start each new paragraph. 

11.​Print a copy of the T1-ADJ and mail it to the CRA. There's no need to submit a full return. 

 

Mailing form T1-ADJ 

The CRA keeps a list of all tax centers where T1-ADJs can be sent.  
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Review the CRA list here.  

 

Related Articles 

Review our support article on adjusting a T1 for additional details. 
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Using ReFILE for T1 in ProFile 

If you are an EFILE service provider, you can use ReFILE to send T1 adjustments online for tax years 2018–2024 for your clients. The ReFILE 
service allows you to change the same lines that individual taxpayers can with the Change my Return service in My Account.​
 

Who can use ReFILE?  

Preparers can use the ReFILE service under the following 
conditions:  

●​ You have a file for tax years 2018-2024 
●​ You have level 2 authorization from your client 
●​ The initial return was filed online via EFILE 
●​ The initial return was assessed 
●​ You have acquired a new sign-off for a revised T183 

from client 

What tax years does ReFILE support? 

ReFILE is supported for 2018-2024-tax years with the latest ProFile version. 

Undertaking the ReFILE process 

1.​ Open a T1 return that has already undergone EFILE and for which a CRA assessment has been received. 

2.​ Save the return as a new file, using the Save As... option from the File dropdown menu.   

3.​ Enter the new information that requires a ReFILE into the return. For example, a client has received an unexpected T4 indicating 
additional income.  

4.​ Open a T1ReFILE form. 

5.​ Ensure the client information (SIN, Name) is correct and enter the current date in the Date of ReFILE field. 

6.​ Select the Yes option in the Is this an amended tax return? field. 

7.​ Reprint and get the client to sign off on a new T183. 

8.​ Select the EFILE/ReFILE this return option from the EFILE dropdown menu.  

✅You will get a new confirmation number on the return’s Info page.  
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Using Pre-Authorized Debit (PAD) for T1 in ProFile 

Pre-Authorized Debit (PAD) is a CRA feature that allows tax professionals to submit a payment to CRA for taxpayer clients who have an 
amount due on their current-year T1 Personal returns. This feature saves the taxpayer time over printing a T7DR(A) form and making the 
payment in-person at their Bank. 

⚠️Note: Complete a PAD and EFILE it for each taxpayer. If there's a spouse with balance owing, the spouse requires his or her own PAD 
form to be completed and undergo EFILE.  

Completing the PAD Form: 

1.​ Complete the taxpayer’s T1 Personal return in 
ProFile and EFILE. 

2.​ Select the Form Explorer option from the ProFile 
GoTo menu. 

3.​ Search for T1PAD and open the PAD form. 

⚠️Note: If the taxpayer has completed the T1DD form, 
you can retrieve their banking information from the T1DD 
to automatically populate the PAD form. 

4.​ Change the Do you wish to set up 
Pre-Authorized Debits (PAD) for current year 
tax owing value from No to Yes. 

5.​ Enter the amount to be paid into the Total amount you would like to pay through PAD (single one-time payment) field. 

6.​ For payment in full, check the Pay in full checkbox. For partial payment, enter the amount in the value field. 

7.​ If not using the same information as the Direct Deposit Request, enter details of the bank and account the payment is being made 
from. 

8.​ Enter a payment date. The date must be between five business days (not including holidays) and one year in advance of the current 
date. 

✅The PAD form is completed. 
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EFILE the PAD Form from the T1 
 

1.​ Return to the taxpayer’s T1 form that underwent EFILE. 

2.​ Select the EFILE Pre-authorized Debit for this taxpayer... option from the EFILE dropdown menu. 

The PAD form is sent to EFILE. The Preparer gets a confirmation number. This number is used to fill out the PAD form (field T1PAD 
confirmation number) and on the information page after the EFILE. 

Additional information 

Read the CRA guide on PAD for more information.  

Review our support article on PAD for ProFile customers. 
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Managing T2 Returns in 
ProFile 
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Overview of T2 Module in ProFile 

A T2 is the federal tax return for incorporated businesses (also called corporations). An incorporated business must complete a T2 return 
each year, even if there is no tax payable. 

The form must be filed within six months of the end of each corporation's fiscal year. 

The CRA requires that any T2 returns being filed electronically must be filed via the EFILE service. 

 
Required information and material for T2 returns 

For the best-possible experience, assemble the following information and materials prior to undertaking the T2 return:  

●​ Prior-year financial statements and T2 return, if applicable 
●​ Articles of incorporation 
●​ List of product and services provided in percentages 
●​ Obtain backup electronic copies of applicable bookkeeping (for example, QuickBooks, Simply accounting, MS Excel, etc.), trial 

balance, balance sheet, income statement, general ledger, credit card and bank statements of the last month of the corporation year 
●​ Corporate installment payments made during the year 
●​ Copy of prior years' Notice of Assessment (NOA) 
●​ Correspondence with any government relating to the corporation 
●​ List of changes to the corporation from last year (for example, new director, shareholders, new assets, etc.) 
●​ Business number of the corporation (review the incorporation documents or prior-year return) 
●​ Address of corporation, including head office, mailing, and location of books, if applicable (you can review the CRA My Account 

feature for this information) 
●​ Fiscal year-end date of company 
●​ Enter information and carry-forward the return in ProFile of the prior-year corporation return, if available  
●​ Provide a signed business consent form to obtain access to the client’s business information through the CRA (support article)  
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T2 Guide and In-Product Tutorial in ProFile 

ProFile provides customers a T2 guide that includes a list of steps a user should understand to file a corporate return. 

⚠️Note: The T2 guide covers basic steps for filing a T2 return but doesn't provide any tax-related advice or opinion. If you aren't a 
designated accountant, ProFile suggests looking at the CRA website, calling the CRA tax help line, or speaking with a CPA firm that is 
approved to help you with current tax laws. ProFile also recommends having any return 
prepared or reviewed by a professional accountant before filing.    

Review our T2 support article.  

ProFile has a T2 tutorial that shows how to fill out and file a corporate return.​
 
To access the tutorial: 

1.​ Open a T2 return. 

2.​ Select the 1. Getting Started option under the Training > T2 dropdown menu. 

The T2 tutorial opens. 

3.​ Select Next to proceed through the tutorial. 

 

 
136 

 

https://profile.intuit.ca/support/en-ca/help-article/tax-return/profile-t2-return-guide/L2WOA7BPN_CA_en_CA?uid=miyznl2b?src=ProFileUserGuide


 

Submitting and Canceling Business Consent 
 

Prior to ProFile release 2019.3.0, Preparers used forms RC59 and RC59X to submit and cancel a Business Consent with CRA. Forms RC59 
and RC59X were updated in ProFile release 2019.3.0 to let electronic approval of two services: permission to access client information via 
online, phone, and mail methods, and the cancellation of existing client access. 

Review our support article on the new process for submitting and canceling a Business Consent. 
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EFILE form MR-69 in ProFile for T2 
 

The MR-69 form is the Authorization to Communicate Information or Power of Attorney form in ProFile. 

ProFile users can upload a signed copy of the MR-69 for RQ to retain in their records using ProFile version 2019.3.0 or later. 

Review our support article on the process for T1 and T2. 
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Using Form T1044 in T2 module 
​
Form T1044 Non-Profit Organization (NPO) Information Return is for non-profit organizations as described in paragraph 149(1)(I) of the 
Income Tax Act, and organization described in paragraph 149(1)(e) of the Act. 

Search in ProFile for T1044 to find the form. 
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Using T1134 EFILE for T2 in ProFile 
​
ProFile users can electronically file the T1134 - Information Return Relating to Controlled and Not-Controlled Foreign Affiliates for your 
client in the T2 module. 

The T1134 return can undergo EFILE before or after filing the T2 return. 

 

EFILE the T1134 Return: 

1.​ Open the T1134 return undergoing EFILE. 

2.​ Select the EFILE the T1134 option from the EFILE dropdown menu. 

3.​ Select OK when presented with a request for confirmation. 

⚠️Note: Select the Don't show this warning again option to avoid seeing the confirmation message in subsequent EFILE efforts. 

4.​ Clear any audit messages before transmitting the form. 

If the return transmits successfully, ProFile displays a confirmation number. Retain this number for your records. 

If the return transmission is unsuccessful, ProFile displays ‌errors identified by the CRA. Correct any errors and resubmit the return. 

​
Amending a T1134 Return for a Supplementary Deletion: 

⚠️Note: An amended return is only filed electronically if the original return was filed electronically. ProFile customers can electronically 
change a T1134 return that underwent EFILE and needs to be deleted.  

1.​ Open the TT1134SUPP form to delete.  

2.​ Select the Delete Form option from the Form dropdown menu.  

3.​ Select the reason for deleting the Supplementary from the dropdown menu: 

●​ Duplicate 
●​ Filed in error 
●​ Other 

The T1134SUPP form is marked as Deleted for transmission to the CRA.  
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Importing GIFIs into ProFile 
 
Using GIFI Import from Caseware for T2 in ProFile 
​
The General Index of Financial Information (GIFI) is a comprehensive list of financial statement items where each item has a unique code. It 
allows a corporation to report its unique combination of accounts to the CRA. 

Importing GIFI from CaseWare to ProFile​
​
In Caseware: 

1.​ Open Caseware. 

2.​ Open the Working Papers client file from which to export. 

3.​ Select the GIFI option from the Export menu, the Export of Data to GIFI dialogue box displays. Complete the fields in the dialogue 
box. 

4.​ Select OK. The export process creates the GIFI file. 

​
In ProFile: 

1.​ Open a T2 return. 

2.​ Select the Import… option from the File dropdown menu. 

3.​ Select the location where the Caseware-created GIFI file is stored. 

4.​ Select the GIFI file (*.gfi). Select Open. The Import Successful dialogue box displays X. 

5.​  Select OK. 

The GIFI information imports to the T2 return in S100 and/or S125 depending on the mapping used. 

 

Related Articles 

●​ Review our support article on GIFI import from QuickBooks Online (QBOA).  
●​ Review our support article on GIFI import from QuickBooks desktop to ProFile T2. 
●​ Review our support article on Caseware and exporting GIFI data for imports. 
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Using GIFI Import from QuickBooks Desktop for T2 in ProFile 
 

⚠️Note: It's necessary to undertake QuickBooks integration prior to importing GIFI from QuickBooks Desktop. This guide includes a 
QuickBooks Integration section. 

About GIFI Import 

The General Index of Financial Information (GIFI) is a comprehensive list of financial statement items where each item has a unique code. It 
lets a corporation report its unique combination of accounts to the CRA.​
 

Importing GIFI from QuickBooks desktop: 

1.​ Open a T2 return in ProFile. 

2.​ Ensure that the ProFile T2 taxation year matches the corresponding year entered in 
QuickBooks. 

3.​ Select the Yes option for the question Complete return from GIFI? in the Filing section of the ProFile T2 return. 

4.​ Select the QuickBooks Desktop Import… option from the File dropdown menu. 

5.​ Set the Year start and Year end values in the GIFI Data Import window. 

6.​ Select Continue. 

7.​ Review the amounts being imported from QuickBooks to ProFile. 

8.​ If correct, select Import. 
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Using GIFI Import from QBOA for T2 in ProFile 
​
The General Index of Financial Information (GIFI) is a comprehensive list of financial statement 
items where each item has a unique code. It lets a corporation report its unique combination 
of accounts to the CRA. 

⚠️Note: Only tax year 2015 and forward are supported. 

 
Exporting GIFI from QBOA 

1.​ Log in to the QBOA Firm containing the data to export. 

2.​ Access the client’s QuickBooks Online (QBO) subscription from the Go to QuickBooks 
menu or by selecting the QB symbol to the left of the company name. If you’re not 
logged into the client file, login here. 

3.​ In QuickBooks Browse to the Books to Tax  option on the left navigation pane and select Workpapers from the sub-menu. 

4.​ Review the Trial Balance in the Review and Adjust tab.  

5.​ Create Groups & move Chart of Account 
General Ledgers (GLs) into those groups to 
prepare for GIFI mapping.  The total of the GL 
accounts in each group will appear on the line 
that is mapped on the S100 or S125. 

6.​ Review the GIFI Mapping from the Income Tax  
section beside Workpapers to ensure that all the 
work is completed. If there are any unassigned 
codes, these can be mapped under the Income 
Tax section. To assign GIFI Codes, look at the list 
and choose Assign GIFI Codes. Use the pencil 
icon to change existing mappings at the GL 
level. Save the changes after each change. 

7.​ Select Books to Tax Actions. 

8.​ Select Export GIFI file. 

9.​ Select the destination on your computer where you would like to save the GIFI (*.gfi) file. 

 
143 

 

https://ca.qbo.intuit.com/app/trialbalance


 
Importing GIFI into ProFile 

1.​ Select the QBOA Import… option from the File dropdown menu. 

2.​ Browse to the GIFI file to import. 

3.​ Select the GIFI file and select OK. 

The GIFI information imports in S100 and/or S125 depending on the mapping used. 

✅The process is complete.  
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Using CRA Data Import with AFR for T2 in ProFile 
​
Auto-Fill My Return (AFR) is a secure CRA service. It allows authorized representatives to electronically request and receive certain tax 
information to fill in parts of their client’s corporate income tax return.  

Acquiring AFR permissions 

The tax Preparer must have a valid authorization from the taxpayer to access the Represent a Client website. There are two ways to acquire 
this authorization: 

●​ The taxpayer can access CRA's Business Account service. Preparers request that the taxpayer enter the Rep ID to authorize the 
Preparer as an individual, a Group ID to authorize a group of representatives, or a business' Business Number (BN) to authorize all 
employees of a business 

●​ Request the permission of the taxpayer via a Business Consent submission as noted in the Business Consent section of this guide. 
 
⚠️Note: To learn how to obtain Represent a Client access, review this CRA article. 
​
Importing data with AFR 

1.​ Open or create a T2 return.​
 

2.​ Select the Auto-fill My Return (AFR) option from the File dropdown 
menu. The CRA Data Import Tool window displays.​
 

3.​ The CRA login window will open in a new window and the instructions 
will display.​
 

4.​ Make sure the CRA data request information is correct and select Next.  
The CRA system processes the request. The Successfully Connected 
message displays when the connection has been made between the 
ProFile and CRA systems.  

5.​ Return to the ProFile window, where a list of available client data options 
displays.​
 

6.​ Select Next. ProFile shows Downloading CRA client data, then Data 
download completed​
 

7.​ Select Continue. ​
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8.​ ProFile’s Data Import Worksheet window displays..​

 
9.​ Review the data. Select Transfer Selected to transfer data to applicable forms. ​

 
10.​To review the data imported, select the Data Import tab in ProFile's Auditor. 

⚠️Tip: If you have used AFR before and are using it again, make sure you uncheck 
items that have already been imported. This can cause duplicate imports that can add 
too much information.  This reduces the need to delete duplicate information. 

 

For more detailed instructions on AFR, please review our support article.  
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Attaching Documents for EFILE of T2 Returns with the Attach a Doc Feature 

CRA allows corporations to transmit supporting documentation via ProFile’s Attach a Doc feature within 24 hours of the EFILE of a T2’s initial 
or amended return. 

The following file types can be used as attachments: 

●​ .pdf 
●​ .doc 
●​ .docx 
●​ .xls 
●​ .xlsx 
●​ .rtf 
●​ .txt 

●​ jpg 
●​ .jpeg 
●​ .tiff 
●​ .tif 
●​ .xps 

 
 
What’s the maximum attachment size? 

The maximum attachment size is 150 megabytes (MB). This is a CRA limitation. 

Is there a limit to the number of attachments transmitted? 

If the attachments are sent within 24 hours of the T2 return, there's no limit to how many attachments can be sent. 

Can I make attachments prior to the T2 return being transmitted? 

Yes, but the T2 return must be transmitted first before the attachments. 

​
Related Articles​
​
Review our support article on using the Attach a Doc feature for T2.  
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Corporate Linking for T2  
​
T2 filers can now link data from a related or associated corporation into the RAC Details form of another corporation using ProFile's 
Corporate Linking function.   

Any changes to the data of a related/associated corporation found within a RAC Details form highlights and can synchronize easily. 

​
Who can use Corporate Linking? 

Any ProFile customer who has the T2 module is eligible to use Corporate Linking.​
 

For which tax years is Corporate Linking applicable? 

Corporate linking is available for T2 returns in the 2015–2018 module or later. ​
 

Will Corporate Linking work for OnePay and Trial licenses? 

Yes.​
 

Linking a Related or Associated Corporation to a T2 Return 

1.​ Open the T2 return. 

2.​ Select the Link  icon to link a related/associated corporation.  

3.​ Browse to the folder containing the return being linked. 

4.​ Select the T2 return file of the related/associated corporation being linked. 

The details of the related/associated corporation display. 

5.​ Select or unselect the related/associated corporation's data. 

6.​ Select Confirm. 

All selected related/associated data is imported and linked. 
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The RAC Details of the newly linked corporation displays, and the designation Linked is assigned for it in the left-side display menu.​
 

Reviewing Related/Associated Corporation Status 

The status of related/associated corporations that are linked—or have been linked previously — to a corporation is displayed in the left—side 
menu of the linking window. 

The following designations can apply to related/associated corporations: 

Linked: The related/associated corporation is linked. 

Manual: The related/associated corporation isn't linked, 
but the RAC Details information exists and may be linked. 

Broken: The related/associated corporation was 
previously linked but has since been renamed or moved 
from its former location (for example, the original file 
folder or directory). To relink the related/associated 
corporation, locate the file and select Confirm or revert to 
the original file name. 

⚠️Note: When you have linked companies, only one company can be open at a time. Otherwise, the Link breaks and goes back to 
manual.​
 

Related Articles 

Review our support article for additional details and troubleshooting tips. 
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Special Election and Return Filing (SERs) 
 

You can file Special Elections and Returns (SERs) online. You can also bring supporting documents when you file them. SERs can be filed at 
any time. 

Supported special election returns 

T2 Module, business returns 

For business returns, you can use your EFILE number or DAC. All returns support document upload. 
●​ S89 
●​ T2054 

 
FX module business account 

For business returns, you can use your EFILE number or DAC. Returns that support documents upload: 
●​ T2054 
●​ T2058 
●​ T2057 
●​ T2059 
●​ UHT2900 (This form doesn't support document attachments) 

 

Frequently Asked Questions 

Can I file the information return and attachments at the same time? 

Yes, you can file with the return or after the return is filed. You must file attachments within 24 hours of filing the return. Outside of this 
timeframe, ‌attachments must be submitted through the CRA website within 7 days. 

What filing methods can be used to file SERs returns and attachments? 

You can use an EFILE number, a DAC for business returns, or request a DAC to use in ProFile. If you're filing for the first time, contact the 
CRA help desk for a DAC, since it's not available through ProFile. 

Can I use DAC to file my individual forms? 

No. You need an EFILE number to file any individual forms/documents. 
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When should I use a DAC versus a Web Access Code (WAC)? 

A WAC is requested from the CRA through ProFile for NetFiling T2 returns. DAC can be requested from the CRA using ProFile, for Business 
SERs designated forms (S89, T2054, T2058, T2057, T2059, UHT2900). 

⚠️Note: You'll need your business's latest Notice of Assessment (NOA) or Reassessment (NOR). If you're filing for the first time, contact 
the CRA help desk for a WAC or DAC, as it's not available through ProFile. 

How long does it take to get a DAC through ProFile from CRA? 

If you are eligible, the CRA will issue you a DAC right away, but has changed the process for security reasons.  Please review this article for 
updates to the process of requesting a DAC 

Where are my auditor tabs? 

The auditor window will resize according to your screen size and resolution. To view all auditor tabs, click on the arrows on the right side of 
the auditor window. 

 

Learn more about SERs in ProFile in our support article.  
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Using the T2 Print Interface Experience 
​
The T2 print interface uses dynamic menus. This means that only when you select a function (print, email, archive) will the related menu 
options display in the print interface. This helps keep the print interface clean and simple, as you see only the options for the function 
activated. 

Using the new print interface is currently an optional experience. Preparers can still find the previous print interface in ProFile.  

Select the Print Setup option from the File dropdown menu.  

Unselect Enable new T2 print menu option box, and then select OK, the old print interface menu displays. 

 
Accessing the T2 print interface: 

1.​ Ensure you are using the latest ProFile release. 

2.​ Open the existing T2 return.  

3.​ Select the Print Setup option from the File dropdown menu , the Print Setup menu displays. 

4.​ Select the Enable new T2 print menu option box and select OK. 

5.​ When you select File > Print or <Ctrl+P>, the new print interface menu displays.  

 

Using the Job Selection section 

This feature is available in 2017 modules and later.  When you go to print a return, the Job Selection feature pops up.  The Job Selection 
section lets Preparers to Browse between types of returns and assign 
parameters for print, email, archiving, and language. The Job Selection 
dropdown menu populates automatically with print details based on the 
open T2 return.  

Preparers can select a single return type to print, archive, or email from the 
dropdown list (for example, T2 Paper).  

Alternatively, Preparers can select multiple types of returns to print or email 
from the dropdown list (for example, T2 Paper and ATI1). If you select 
multiple types of returns, a tab for each type will appear below the Job 
Selection. 
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The details of the selected items display. 

The details presented include email, archive, and print options for each item in the return, as well as language preferences and assigned 
printers. 

​
Using the Archive PDF section 

Preparers can set the file location and file name for archived forms in the new printer interface. 

1.​ Select the Archive option under the job selection to access the Archive PDF Options menu in the new print interface.  

2.​ Preparers can select two options for archived PDF locations:  

●​ Select the Same folder as client file option. This places the PDF in the same 
folder as the existing client file, or: 

●​ Select the Specify a folder option. Select Browse to choose a folder for the 
archived PDF file. 

⚠️Note: The default archive locations pre-populate from the PDF tab in the 
Environment Options window.  

3.​ Select Continue to save the selections. 

Preparers can select two options for archived PDF file names: 

●​ Select the Same as ProFile tax file name option. This names the archived PDF with 
the same file name as the tax file, or: 

●​ Select the Use Custom option. Use + and —to assign file name parameters such as 
name, month, day, time, year end, and more: 

Select Continue to save the selections. 

 

Using the Email Options section 

Preparers can set parameters in the Email Options section for email templates and email 
addresses. 

1.​ Select the Email option under the job selection to access the Email Options menu 
in the new print interface.  
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2.​ Select the available email template from the dropdown menu.  

⚠️Note: Email templates source from the designated ProFile Templates folder.  

3.​ The client's email address—as set on the return—automatically populates in the Email Address field. If no client email address is set 
on the form, enter the address manually.  

4.​ Select Continue to retain email settings.  

The Preparer’s email program opens a new draft email with the template and client email already entered.​
 

Related Articles 

Review our support article for additional details. 
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Using EFILE with Web Access Code (WAC) for T2 in ProFile 
​
A Web Access Code (WAC) is a secure, personal code given to you by the CRA to prove your identity. The CRA gives this code to tax 
Preparers to file certain business returns and information slips electronically. Using a WAC helps ensure that the filer's identity is 
authenticated, adding an extra layer of security to the filing process. 

For more information on Digital Access Codes (DAC), check out our article. 

The CRA now needs your business' information from the most recent Notice of Assessment (NOA) or Reassessment (NOR) to request a 
WAC. 

⚠️Note: If this is your first time filing and you’re requesting a WAC, contact the CRA help desk to get one. 

​
Applying for a WAC: 

1.​ Select the Transmit this return… option from the EFILE dropdown 
menu. 

2.​ ProFile reviews the T2 return for any outstanding warning. If there are no 
auditor warnings, ProFile displays a green checkmark.  

3.​ Select OK. 

The Corporation Internet Filing window displays.​
 

Select the Authorization method 

●​ File return with EFILE Number an Password: This allows EFILE users to 
use their existing credentials.​
 

●​ File return with Web Access Code (WAC): This option will expand the 
window to either use a WAC Code issued to you or request one on if you 
do not have EFILE credentials. 

4.​ If requesting a WAC, enter the date of the most recent NOA/NOR and complete correct information in one of the three fields from 
that NOA/NOR before selecting Request. 

5.​ Select Next to transmit the return. 
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⚠️Note: If you aren't ready to transmit the return at this time, the WAC code will remain in this field until the return is transmitted. 
Remember to save a copy of the WAC for your records. You may need it later. 
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Using Amendments for T2 in ProFile 
​
T2 amendments are carried out when a new piece of information 
demands that the original T2 be amended to reflect the new data. 

Saving the original T2 return: 

ProFile strongly recommends that the file be renamed before changing 
the return. This ensures the original T2 isn't lost in the process of being 
changed. 

1.​ Open the T2 return that requires amendment. 

2.​ Select the Save As… option from the File dropdown menu. 

3.​ Save the T2 return as [Your Corp Name]_amended.  

 
Amending the corporate information page: 

1.​ Select the Info tab in the T2 return. 

2.​ Set the following values in the Filing section:  

●​ Is this an amended return? Is set to Yes 
●​ Internet file this return? Is set to Yes 

3.​ Select the Yes value on line 997 of the T2 Adjustment 
worksheet. 

4.​ Enter a description of the amendment in the field at line 996. 

 

Restrictions 

The following fields can't be changed under this process. ProFile 
displays a warning message if an amendment is submitted regarding one of these fields. These fields must be changed via the CRAs login 
services: 

●​ Head office address change 
●​ Mailing address change 
●​ Location of books and records change 
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●​ Direct deposit information 
●​ Language of letters​
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Managing T3 Returns in 
ProFile 
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Overview of T3 Module in ProFile 
​
About T3 tax forms 

A T3 Statement of Trust Income Allocations and Designations shows investment income from mutual funds in non-registered accounts and 
from certain trusts. In Québec, the form is a relevé 16 (RL16). The income may come from individual investments or from an estate trust as 
inheritance tax. 

Amounts present in box 51 and/or 39 show a dividend tax credit available. 

T3 slips show income from interest, dividends, and capital gains. All these types of income are taxed at different rates. 

 

Receiving the T3 tax slip 

Usually, T3 tax slips are received around March 31. 
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Key Forms for T3 in ProFile 
​
There are some key T3 forms to be mindful of when completing a trust return: 

​
Beneficiary form 

Use the Beneficiary details form to enter information for trust beneficiaries. Amounts flow from the Beneficiary details form to the 
corresponding T3, NR4, and RL16 slips. ProFile also uses the Beneficiary details form to complete Schedule 9 in the trust return.  

​
Allocation worksheet 

Use the Allocation worksheet to show how the trust allocates income to beneficiaries. If the trust is claiming expenses at line 41 of the 
return, apply the expenses to specific types of income before allocating income to the beneficiaries. The trust gets a deduction on the T3 
jacket for income that is allocated to the beneficiaries.  

Some of the trust income may be taxed in the trust. Specify for each type of income the amount that the trust will retain. ProFile displays the 
remaining income as the amount to be allocated to the beneficiaries.  

On the Allocation form, Preparers may also need to enter certain T3 slip amounts, such as a retiring allowance, death benefit, or foreign 
business income.  
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Data Entry and Flow for T3 in ProFile 

The T3 Info form contains sections for general information, trust type, and other basic details of the trust. 

Preparers will report income, deductions, and general information about the trust. This information will be kept in the beneficiary 
worksheet. On the Beneficiary worksheet, enter details such as the beneficiary’s name, address, and what kind of beneficiary (Individual vs. 
Corporation/Organization).  

There are numerous data entry forms, including business and rental statements, dispositions on Schedule 1, and T3 and/or T5 
income received by the trust. 

If the trust is giving money to its people, the forms in the Beneficiaries tab of the Form Explorer are important. 

Any income not allocated to beneficiaries is taxed on Schedule 11, which transfer to page 4 of the T3 jacket. 

 

About the Beneficiary worksheet 

On the Beneficiary worksheet, enter details such as name, address and 
residency of the beneficiary. The slip amounts at the bottom of this form 
are calculated using amounts from the Allocation worksheet multiplied 
by the percentage applicable to the particular beneficiary (percentage 
is on the Beneficiary worksheet).​
 

Locating the Beneficiary worksheet 

On forms like Benfeciary, where there are an unlimited number of 
slips, browsing is simplified with the following shortcuts: 

●​ Use the horizontal scroll bar to Browse. 

●​ <Ctrl + Enter> takes you to the top of the next slip 

●​ <Shift + Ctrl + Enter> takes you to the previous slip 

●​ <Ctrl + Right Arrow> and <Ctrl + Left Arrow> take you to the 
next or previous column (and scroll to the next or previous slip 
accordingly)​
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Using the Beneficiary worksheet 

The information on the Beneficiary worksheet transfers to the T3 and NR4 slips. These slips are for reporting and preview purposes only: 
Data can't be edited on these forms. 

The data from the T3 and NR4 slips is posted to the T3 Summary and NR4 Summary.  

Schedule 9 is a summary of the amounts allocated/designated to the beneficiaries. ProFile completes this form using the amounts from 
the “Beneficiary” worksheet. The trust gets a deduction for the total income allocated to beneficiaries at line 928 of this schedule. 

Check the T3 jacket and add data to any fields that ProFile T3 doesn't calculate (especially the questions on the first two pages).  

 

About the Allocation worksheet 

The Allocation worksheet is used to complete the slip amounts 
for beneficiaries.   

Use this worksheet to:  

●​ Choose how you want the money to be split between 
the people you want to help. The default is that each 
person gets the same amount of money. If not the case, 
choose Other and enter the percentage applicable to 
each beneficiary on the Beneficiary details worksheet. 
If Other is selected, the percentage field on each slip of 
the Beneficiary worksheet becomes an input field. 
Otherwise, it's calculated based on ‌an equal allocation 
to all beneficiaries. 

●​ If the trust has claimed expenses at line 41 of the return, 
the expenses must be applied to specific types of 
income before the income can be allocated to a 
beneficiary. These expenses must be applied manually: 
An audit message will appear if these expenses haven't 
been entered. 

●​ To retain some of the income to be taxed in the trust. You can specify which type of income and how much is to be retained by the 
trust. 

●​ To specify amounts for certain boxes of the T3 slips ProFile T3 doesn't automatically complete that, and the information must be 
entered manually. For example, details related to foreign income and tax paid. Also, if the trust is allocating a retiring allowance or 
death benefits, those amounts must be specified here. 
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Using EFILE Slips for T3 in ProFile 
 

About T3 slip EFILE 

A T3 Trust return must still undergo paper filing. However, the Slips Summary can undergo 
EFILE with the related slips. 

⚠️Note: always print or retain a PDF copy of the CRA confirmation of an EFILE when 
completed. ProFile doesn't retain a report or record of which slips are transmitted.​
 

Transmitting slips: 

1.​ Prepare the T3 slip in ProFile. 

2.​ Open the Beneficiary details form and select the Type of slip being transmitted.                                       

3.​ Select the Transmit Slips option under the EFILE dropdown menu. 

4.​ Select the appropriate option under the Data type dropdown menu, and then select 
OK. 

ProFile builds the XML file and automatically launches the CRA transmission window. 

5.​ Review the CRA disclaimer, sign in with your CRA credentials, and submit the XML file.  

6.​ The file submits. Select the Print icon on the browser window to print the confirmation 
number. 

7.​ Select Close. 

⚠️Note: Ensure you have a Business Consent filed with the CRA prior to attempting the 

EFILE of T3 slips or returns.  
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EFILE a T3 Return in ProFile 

Beginning with the release of 2021.3.0, returns with a year end of 2021 or later will be able to be electronically filed using CRA EFILE 
credentials. Returns are still required to not have any exclusions on the T3Efile 
worksheet. 

A newer section on the Info page under Filing will default to Yes if a T3 is eligible 
for EFILE and No if not. 

Slips and summaries must still be transmitted via XML filing. 

1.​ To EFILE the return, select EFILE in the menu bar and then Transmit T3 
return. 

The interface displays.  

2.​ Select the type of T3 you are filing and select Next. 

If your T3 file has EFILE errors, you'll see a rejection box outlining what needs to 
be corrected. 

Returns are submitted to CRA in JSON format. The JSON along with the 
acceptance or rejection message will be stored in the folder selected in the T3 
EFILE -> Options directory. 

The confirmation number displays on the Info page if successfully transmitted. 
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XML File a T3 Return in ProFile 
​
Preparers using ProFile release 2017.2.5 and later can transmit eligible Trust Returns using the Canada Revenue Service’s (CRA) Internet file 
transfer service. Although EFILE is available to file T3 returns, some preparers may prefer to submit these returns via XML filing. 

​
How does the XML filing for a T3 return work? 

Transmitting an XML file electronically to the CRA is different from the EFILE process.  

An XML generates based on the information provided on the T3 return. This XML file transmits to the CRA via ProFile.  

The CRA issues a confirmation number following submission to confirm the receipt of the XML file.  

The Preparer inserts the CRA confirmation number on the T3 return. 
 
What are the requirements for the XML filing of a T3 return? 

The CRA maintains a detailed list of restrictions for filing a T3 return electronically.  

Review the list prior to undertaking an XML filing. 
 
What tax years are eligible for the XML filing of a T3 return? 

XML filing for T3 returns occurs for 2017-2020. A T3 return undergoing XML filing can't have a year-end date prior to January 1, 2017. 
Returns later than 2020 can be EFILED. 

Preparing a T3 return for XML filing:  

1.​ Open ProFile. 

2.​ Prepare the T3 return.  

3.​ Resolve any error messages displayed under the MagMedia tab of the Active Auditor. 

If the information on the return is complete, valid, and eligible for the Internet file transfer service, the Internet file this return? Question in 
the return’s Filing section of the Info form checks automatically.  

⚠️Note: If the return isn't valid, the question remains unchecked and prevents the XML file from transmitting. See section Using the T3 
EFILE below for resolution. 
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XML filing a T3 return:  

1.​ Open the populated T3 return.  

2.​ Select the Transmit T3 Return option from the EFILE dropdown menu. The Transmit T3 Return window displays.  

3.​ Select a return type (for example, T3 Return).  

4.​ Select OK. The XML file builds.  

If successful, a message indicating the processing and completion of the XML build displays. 

5.​ Select OK.  

ProFile automatically opens the CRA transmission window.  

6.​ Enter the Preparer account number and Web access code when prompted. 

7.​ Select Next. The Internet file transfer – attach your return window displays.  

⚠️Note: The XML file path already populates in the directory field. To search for a different XML file, select Browse.  

8.​ Select Submit. The XML file transmits to the CRA.  

The CRA provides a confirmation number following transmission.  

9.​ Manually enter the confirmation number in the Confirmation Number field of the T3 return’s Filing section.  

10.​Save the return. 

 

Related Articles 

Review our support article for additional details. 
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Early Filing Next Year for T3 in ProFile 

The next year’s T3 module in ProFile isn't available until the year after. For example, when the 2024 T3 module is the last one released and 
you need to prepare a T3 return with 2025 year-end, the 2025T3 module isn't available until January of 2025.  In this situation, the previous 
year’s T3 module is used for preparing next year’s T3 return.​
​
​
New tax rate implementation 

New tax rates are implemented in the previous year’s T3 module to handle preparation of next year’s T3 returns.  Entering the appropriate 
year-end on the Info page initiates the applicable tax rates for that year.  T3 returns filed using the previous year’s tax forms are acceptable 
to CRA, and they will reassess the return if required.​
​
​
Preparing next year’s T3 return using the previous year’s T3 module: 

1.​ Save a duplicate copy of the previous year’s T3 return to be used as the next year’s T3 return. 

2.​ Open the copy of the previous year-end T3 return in ProFile. 

3.​ Enter the appropriate year-end for the trust return T3 to be prepared. This begins the applicable tax rates for next year. 

4.​ Delete the information pertaining to the previous year-end, keeping what’s required for the next year-end. 

5.​ Enter the T3 data required for filing the next year’s trust return, allocate income to beneficiaries, and create the T3 slips. 

6.​ Print the T3 trust return using File -> Print and print T3 slips using File -> Print Slips. 

7.​ Save the T3 trust return with a different file name to identify the tax rates for that year. 
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Managing Form Expert (FX) 

Module in ProFile 
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Overview of Form Expert (FX) Module in ProFile 

FX and FX/Q includes a comprehensive set of tax forms that are fully interactive, automatically performing all calculations. 

The forms include: 

●​ T4, T5, T5018, T5008, T5013, RL1, RL3, RL15, and more 
●​ Partnership Information Return and Schedules (T5013 Schedules and TP600 for Québec) 
●​ Charity and Non-Profit Organization forms (T3010 and TP-985.22 for Québec) 
●​ Additional GST/HST/QST, TD1, RCA, Nonresident and Recourse forms 
●​ Federal, Québec and provincial rollover forms (T2057, T2058, T2059, TP529, TP614, AT107, AT108 and AT109) 
●​ BC Logging Tax Return of Income (FIN542 and FIN146) 
●​ Other forms (for example, RC199, CPT30, T3D, T3RI, etc.) 

 

Related Articles 

Review our support article for forms and tax slips that can be filed electronically. 
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Verifying Client Data for Form Expert (FX) in ProFile 

Verifying Client Data before filing slips in FX module 

Before transmitting a slip or return information with EFILE, ensure that the file is complete and accurate. ProFile includes audit and review 
tools that can help. 

FX Module: 

1.​ Ensure the question Are you internet filing slips? on the Info form is set to 
Yes. 

2.​ Ensure any messages in the Active Auditor, especially those in the Mag 
Media tab, are resolved. Double-click the message in the Auditor to identify 
the area that needs reviewing. 

3.​ When undertaking the initial EFILE of a slip, Preparers enter the Business 
Number in the EFILE wizard. If transmitter information must be changed in the 
future, select EFILE -> Options -> Transmitter under the T3/FX section. 
Information can be updated as required. 

When ProFile makes an XML file that can be sent, it shows slips and information that is not correct. If the information isn't correct, ProFile 
can't make the XML file. View a summary of the problems affecting a file by selecting the (+) symbol next to a failed file. Hover over the 
message to read the full text.  

A common cause of wrong XML files is when you override fields that are part of the information you want to send. For example, you might 
override a field instead of using amounts that ProFile calculates or takes from another form. Avoid using the override feature whenever 
possible. 

⚠️Note: ProFile can't identify the location of any error. It's necessary to locate the error yourself as a customer. 

 

For more information on entering filing credentials for FX, please review our support article. 
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EFILE Slips for FX Module in ProFile 

⚠️Note: ProFile doesn't retain a report or record of which slips are transmitted. Always print or retain a PDF copy of the CRA confirmation 
of an EFILE when completed.​
  

Setting up transmission credentials 

Before you start, make sure your filing credentials are entered. A transmitter number is no longer needed, but you'll need a Rep ID, trust 
number, business number, or nonresident account number. See our article on entering filing credentials for FX or T3. 

Filing slips 

Select the type of filing you are undertaking: 

⚠️Note: Only current-year slip filing is supported in ProFile at this time. 

 
EFILE original slips 

1.​ Open the FX return in ProFile. 

2.​ Make sure there are no outstanding errors under the Mag Media 
auditor tab. 

3.​ Browse to the Information (Info) form of the return. 

4.​ Select Yes to the question: Are you internet filing slips? 

⚠️Note: The option to Internet file slips won't appear unless this option is set to Yes. 

4.​ Select the Properties option from the File dropdown menu. 

5.​ Review the Slips Status section under the EFiling column. Set the slip status of the 
slip type you are filing to Ready to file. 

6.​ Select the Transmit slips or a T5013 return option from the EFILE dropdown 
menu. 
 

7.​ Select the slip that is set with the Ready to File value. 
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8.​ Select Next. If you don't see Next, check again if there are MM errors in the auditor. The XML file builds after selecting Next. 

9.​ Read the disclaimer and select I agree at the end to give consent for the XML transmission. 

10.​Enter the Account number and Web access code at the CRA portal page. Select Sign in. The XML file transmits to the CRA. 

⚠️Note: Due to changes in CRA requirements, the account number must be manually entered. It must match the number used to build 
the XML file in the Electronic Filing Options window. 

11.​We recommend printing the confirmation after you receive it. 

 

Batch EFILE Slips for FX module in ProFile 

This process requires an FX Web Access Code (WAC) from the CRA. This isn't the same code used for T2 corporate returns. 

Select here to learn more about requesting a WAC from the CRA. 

⚠️Note: To obtain a Web Access Code (WAC) you'll need your business's latest Notice of Assessment (NOA) or Reassessment (NOR). 
This is the same process as receiving a T2 WAC but a separate WAC code is obtained for filing in each module.If you're filing for the first 
time, contact the CRA help desk for a WAC, as it's not available through ProFile. 

Also, you can only file slips from FX online from the Client Explorer database. You can't file slips from Classic Database. 

⚠️Note: ProFile supports filing slips created in the FX module for 2023 and onward. 

Multiple FX slips can undergo a batch transmission using the Client Explorer database.​
 

Starting the Client Explorer database: 

1.​ Select Database… from the Options dropdown menu. The Database/Client Explorer Options window displays. 

2.​ Select the Use Client Explorer option. 

3.​ Select OK. 

4.​ Select the Client Explorer option under the GoTo dropdown menu. 

The Client Explorer displays.​
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Filtering and selecting returns: 

1.​ Select Filter. The filter window displays. 

2.​ Select the checkbox on the FX tab and clear the other module tabs by unchecking them. 

3.​ Select the checkbox for the tax year you want (for example, 2024) on the FX tab. Clear the checkboxes for all other years by 
unchecking them. 

4.​ Select the appropriate checkboxes in the remaining sections of the FX tab to filter for slip details. Clear the other options by 
unchecking them.  

5.​ Select Apply Filters. A list of slips that meet the set slip criteria displays. 

6.​ Select the slips to EFILE. 

 
Building the EFILE Link: 
 

1.​ Select the Build EFILE… link in the top-left Actions menu. 

The Build the XML file window displays. 

2.​ Select the slips to undergo EFILE (for example, T4).  

3.​ Select OK. 

The XML file builds and the CRA Internet File Transfer window opens. 

  
Transmitting the XML file to CRA: 

1.​ Log onto the CRA slip transmission website (you must agree to the terms before you’re able to get to the login screen). 

⚠️Note: Transmission of the XML file requires an FX Web Access Code (WAC). If this is the first time internet filing slips, a WAC request 
must be made to the CRA. Ensure that you print a confirmation copy provided by the CRA for your submission records. 

2.​ Complete the XML transmission process. 
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EFILE Amended Slips for Form Expert (FX) in ProFile 
 

Preparers can electronically file an amended slip through the FX module. 

⚠️Note: ProFile doesn't retain a report or record of which slips transmit. Always print or retain a PDF copy of the CRA confirmation of an 
EFILE when completed.  

 

Transmitting an amended slip: 

1.​ Open the applicable return in ProFile (for example, a T4). 

2.​ Under the Slip type? section, set the type to AMENDED. 

3.​ Make all the necessary changes to the slip. 

4.​ Select File, and then Properties…. 

5.​ Set the Slip Status for Magmedia to Ready to File. 

6.​ Select the Internet File Slips option under the ProFile EFILE dropdown menu.  

7.​ Check the box of the slip to be transmitted (for example, T4). 

8.​ Change the data type to Amended in the Data Type dropdown menu. 

9.​ Select OK. The amended slip transmits. 

ProFile builds the XML file and automatically launches the CRA transmission window. 

10.​Review the CRA disclaimer, log in, and submit the XML file.  

11.​The file submits. Select Print to print the confirmation number. 

12.​Select Close. 
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EFILE a Canceled Slip for Form Expert (FX) in ProFile 

Preparers can electronically file a canceled slip through the FX module. 

⚠️Note: ProFile doesn't retain a report or record of which slips are transmitted. Always print or retain a PDF copy of the CRA confirmation 
of an EFILE when completed.  

 

Transmitting a canceled slip: 

1.​ Open the applicable return in ProFile (for example, a T4). 

2.​ Under the Slip type? section, set the type to CANCELED. When transmitting, the slips automatically revert to a value of 0. 

3.​ Select the Properties… option under the ProFile File dropdown menu. 

4.​ Set the Slip Status from Magmedia to Ready to File. 

5.​ Select the Internet File Slips option under the ProFile EFILE dropdown menu.  

6.​ Check the box of the slip to transmit (for example, T4). 

7.​ Change the data type to Cancelled in the Data Type dropdown menu. 

8.​ Select OK. The amended slip transmits. 

ProFile builds the XML file and automatically launches the CRA transmission window. 

9.​ Review the CRA disclaimer, login, and submit the XML file.  

10.​The file submits. Select the Print icon on the browser window to print the confirmation number. 

11.​Select Close. 
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Transmitting RL Slips for Form Expert (FX) in ProFile 

 
Included in the 2018.2.0 and later ProFile release is a revised method for transmitting RL Slips for the 
FX module to Revenu Québec. ​
​
The new process eliminates the need to attach an XML file to the RL slip transmission and instead 
transmits the information directly to Revenu Québec. 

Setting credentials prior to transmission: 

1.​ Select Options… under the EFILE menu .  

The Electronic Filing Options window displays.  

2.​ Select the MRQ Slip Numbers option under T3/FX on the left-side menu.  

3.​ Enter the Magnetic Media slip numbers.  

4.​ Select the Transmitter option under T3/FX on the left-side menu.  

5.​ Enter the Québec Transmitter Number. 

6.​ Select the Contact information option under T3/FX on the left-side menu. 

The Contacts window displays.  

7.​ Enter all requested contact information in the Accounting section. This is essential to avoid 
transmission errors. Requested contact information in the Technical section is optional to 
provide.  

8.​ Select OK. The contact information is saved. 

9.​ Select the Environment… option from the Options dropdown menu. 

The Environment Options window displays.  

10.​Browse to the Preparer tab.  

11.​Populate the fields under the Preparer section. This is essential to avoid transmission errors.  

12.​Enter the Identification Number in the tab.  
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13.​Select OK. 

✅Your settings have been saved. 

 
Transmitting slips: 
 
⚠️Note: The new RL slip transmission process means that an XML file is no longer generated and stored on the user's computer. The 
information is transmitted directly to Revenu Québec.  

1.​ Open the return.  

2.​ Select the Transmit RL slips option under the EFILE dropdown menu. 

The Transmit RL slips window displays.  

3.​ Select the slip(s)s to transmit.  

4.​ Set the slip type in the Type column. 

5.​ Select Next.  

The Ready to transmit window summarizes the slip details.  

6.​ Ensure all slip details are correct before transmitting.  

7.​ Select Transmit. The slip transmits.  

A confirmation displays when the transmission completes successfully.​
​
⚠️Note: Please be aware that there's no retention of slip submissions or results by 
ProFile. 

​
Read our support article for more information, including looking at and printing a transmission confirmation number. 
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Learning More About ProFile 
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ProFile Community and Support Site 

The ProFile Community and Support Site is available to serve our 
valuable customers more effectively. You can now search both our 
support articles and forum questions at the same time, to return the 
best possible answer to your product question.  

Available 24 hours a day, our Community and Support Site has more 
than 1,200 articles designed to improve your ProFile experience. 
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Sending Feedback About ProFile 

ProFile users can easily provide feedback on ProFile’s functionality or suggest an enhancement to the product. 
 
The product owner, developer, or analyst reviews all feedback.  
 
Opening the feedback window in ProFile: 

1.​ Select the Send Feedback option under the Help dropdown menu  or select Suggestion . 

The ProFile Feedback window displays. 

2.​ Describe your idea in the feedback field. You can be as specific as you like.  

3.​ Enter your email so ProFile can contact you in case more 
details are required. 

4.​ Select Submit when finished. 

✅The Additional details window will display. 
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Additional ProFile Resources 

Assisted Onboarding 

This is a resource for new users, included with the cost of your subscription.  This 45-minute call with a product expert, will ensure that you 
have set up ProFile properly so you can get started with your returns.  If you’d like to book an Assisted Onboarding session, select a date 
and time that’s convenient to you here.  During your session, just let the agent know what you need help with! 

Training and Tutorials Site 

Whether you are a new ProFile user or an experienced expert, you can improve your skills with our training resources, video tutorials, and 
Tips and Tricks site. Updated regularly, this site includes both core and advanced information to help you throughout the return preparation 
process. 

Webinars Calendar 

Keep learning with our informative webinars, held every Tuesday and Thursday throughout the year. Live webinars take you through the 
finer points of ProFile, and if you have any questions, our experts are there online with you, ready to answer. 

You can join an upcoming webinar through the calendar. 

In-Product Help 

The in-product Help utility provides an easy way to learn about forms, slips, schedules, ProFile’s functions, and many other topics. Simply 
press the <F1> key from anywhere in ProFile to launch the Help utility. 

Live Chat  

Inside the ProFile software (and on many of our support pages) you will find the Live Chat option. This quick tool lets you talk to one of our 
support representatives online right away, without waiting on the phone or interrupting your work. Available during our regular support 
hours. 

YouTube Channel & Playlists 

You will find several videos regarding ProFile on the Intuit Accountant Canada YouTube Channel. Several playlists can be found such as our 
Training Tour recordings, How to Videos, Tania Talks & Sifa Parle (French).  Remember to sign up for notifications, to ensure you’re up to 
date on any new content in a playlist! 
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